1

I am trying to format the bibliography for the first time, I have installed the IEEEtran package and everything is working except I have a couple of issues, they can be seen in the screenshot. Firstly, I don't understand why the opening quotation mark of the title is so weird — it is different from the closing one, takes much more space and looks awful. Secondly, the IEEE format does not imply double dashes in the pages numbering and I haven't had any luck finding how to change the automatic reformatting. I'd really appreciate someone helping me with these problems. screenshot Here's the main doc code:

    \documentclass[a4paper, 12pt]{article}
\usepackage[a4paper, left=3cm, top=2cm, right=1.5cm, bottom=2cm]{geometry}
\usepackage{fontspec}
\usepackage{setspace}
\usepackage{ragged2e}
\onehalfspacing
\setmainfont{Times New Roman}
\begin{document}
\input{title}
\setcounter{page}{2}
%Abstract
\renewcommand{\abstractname}{\large Abstract}
\begin{abstract}
\normalsize
\singlespacing
    Abstract here.
\end{abstract}
\onehalfspacing
\newpage
%Table of contents
\tableofcontents
\newpage
%Introduction
\section{Introduction}
    Introduction here. \cite{Xconference}
\newpage
%Main section
\section{Literature review}

\newpage

\section{Methods}

\newpage

\section{Results}

\newpage
%Conclusion
\section{Conclusion}
\newpage
%References
\bibliographystyle{IEEEtran}
\bibliography{references}
\end{document}

And here's the references.bib:

    \begin{document}
@conference{Xconference,
    author = "Sourobh Ghosh and Warren Seering",
    title = "Set-based Thinking in the Engineering Design Community and Beyond",
    booktitle = "Proceedings of the ASME 2014 International Design Engineering Technical Conferences \& Computers and Information in Engineering Conference",
    pages = "10-13",
    address = "Buffalo, NY",
    year = "2014",
    month = "17-20 August"
}
\end{document}
2
  • 1
    Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – Adam Liter
    Commented Feb 10, 2015 at 18:42
  • Why do you have \begin{document} and \end{document} in your .bib file? Apart from that I'm not able to reproduce the issues you've described. Try updating your packages. Commented Feb 10, 2015 at 19:27

1 Answer 1

2

I'm guessing you have a TeX distribution with an older version of fontspec which doesn't yet automatically run the option Ligatures=TeX when executing \setmainfont. If you change the instruction to

\setmainfont[Ligatures=TeX]{Times New Roman}

you'll get the typographically appropriate quotation marks and an "en-dash" instead of "--" to denote the range of pages.

While you're at it, you should also change the month field to

month = "17--20 August"

in order to get an en-dash in that field as well.

enter image description here

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .