4

I have a problem with Serbian italics

I have this text, for example:

enter image description here

when I put the name of the book in italics without setting language (Serbian), everything is ok:

enter image description here

but when I set Serbian, I get this:

enter image description here

does anybody know where is the problem? I'm using polyglossia package and Linux Libertine. thank you

EDIT:

picture 1: ИВИЋ,\,П.: Преглед историје српског језика. Сремски Карловци~– Нови Сад 1998.

picture 2: ИВИЋ,\,П.: \textit{Преглед историје српског језика.} Сремски Карловци~– Нови Сад 1998.

picture 3: \textserbian{ИВИЋ,\,П.: \textit{Преглед историје српског језика.} Сремски Карловци~– Нови Сад 1998.}

  • 1
    Can you please add a minimal example of TeX code? – egreg Feb 11 '15 at 21:17
  • The Linux Libertine font has that variant of italic Cyrillic “d” for Serbian. Not sure if you can do anything lest than pretending the language is different. – egreg Feb 11 '15 at 21:22
  • @egreg -- i understand the "d", but not the "g", which is the fourth letter in the same word. it looks like an undotted "i" with either an overbar or a dieresis. – barbara beeton Feb 11 '15 at 21:32
  • yes, there is a problem with letter г and п. its macron, I think – Ashrak Feb 11 '15 at 21:35
  • @barbarabeeton I just saw the “d”; writing it in the shape of a Latin “g” is not so strange, perhaps. Surely the “g” and the “p’ are at least very dubious. – egreg Feb 11 '15 at 21:40
7

It's a precise choice of the font designers. When the language tag is set to SRB, the following substitutions are made in the italic font

enter image description here

I guess this is to imitate handwriting; the CYRILLIC SMALL LETTER PE U+403F is drawn like a “u”, with the macron to represent that the bridge should be at the top (something similar is made in Sütterlin Schrift). Similarly for CYRILLIC SMALL LETTER GHE U+0433, while CYRILLIC SMALL LETTER DE U+0434 is drawn as it is common in handwriting, as far as I know.

You can disable this with a kludge

\documentclass{article}
\usepackage{polyglossia}

\setmainlanguage{serbian}
\setmainfont[RawFeature={language=DFLT}]{Linux Libertine O}

\begin{document}

ИВИЋ,\,П.: \textit{Преглед историје српског језика.} Сремски Карловци~– Нови Сад 1998.

\end{document}

enter image description here

  • thank you very much! I set language to Bulgarian and everything works well now, too – Ashrak Feb 11 '15 at 22:02
  • moved from @user75801's answer: Thanks for your suggestion. I open a new question. If anybody can help, I will grateful. – Symbol 1 Apr 9 '15 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.