6

I have been using texmaker for a long time and I decided to give Kile a try. When I miss-spell a word in Texmaker the spell-checker marks it red and right-clicking on the word shows me possible options.

In Kile this is not the case. On right-clicking a misspelled word, I get to see the different options (like cut paste, spelling etc). Then I have to click spelling and the possible choices pop-up.

It is not an inherently huge problem, but I am wondering is it possible to configure the spell-checking more akin to texmaker?

Am I doing something wrong?

Thanks in Advance!!!

8

Just make sure that automatic checking is enabled:

Tools > Spelling > Automatic Spell Checking

  • That only underlines the miss-spelled words with wiggly red arrows. It doesn't show possible correct options. – DBS Feb 12 '15 at 22:31
  • @DBS Well you have to right-click. Of course, I don't know how it works in your other editor. But I thought you had to right-click there, too. – cfr Feb 13 '15 at 3:48
  • @cfr the problem is that you have to right-click and then make another click on 'Spelling' to see the spell checking options... – AndyK Mar 7 '15 at 12:09
  • @Andyk I don't have to click again. It is in a sub-menu, though, if that's what you mean? – cfr Mar 7 '15 at 12:10
  • @cfr The issue is in KILE you have to do one right-click for the menu and then once more for word choices. In Texmaker one right click shows the possible word choices. One click versus two clicks may not be a lot but it does become inconvenient when you are editing large documents. My question is if this can be modified in kile. – DBS Mar 12 '15 at 11:05
3

I do not have a proper solution for the spelling suggestions being two menus down, but I have a workaround that may improve a heavy user's workflow.

One can use keyboard shortcuts to bring up the spelling window, and immediately accept the first suggestion.

Setup:

  • Tools menu > Configure Shortcuts...
  • Type "Spelling" in the search box
  • Assign a shortcut to "Spelling (from cursor)"

Usage:

  • Move cursor before (doesn't need to be exactly before) the word that's marked as mis-spelled
  • Press the shortcut you set before
  • Hit Alt+R to replace with first suggestion, or choose one of the other options by mouse/shortcut

It sounds complicated, but if the first suggestion is correct, it's a very fast way to correct mistakes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.