10

I am using BibLaTeX and Babel (catalan) and I get a weird error in the bibliography:the quotation marks are replaced by question marks. If a deactivate Babel everything works.

Babel:

Code:

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{setspace}
\usepackage[backend=bibtex,sorting=none]{biblatex}
\usepackage{graphicx}
\usepackage[margin=2cm]{caption}
\usepackage[catalan]{babel}
\usepackage{float}
\usepackage{wasysym}
\usepackage{pifont}
\onehalfspacing
\usepackage[top=0.79in, bottom=0.79in, left=1.18in, right=0.79in]{geometry}
\renewcommand{\thefootnote}{\arabic{footnote}}
\addbibresource{bib.bib}
\begin{document}
[...]
\printbibliography
\end{document}

Result: enter image description here

Without Babel:

Code:

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{setspace}
\usepackage[backend=bibtex,sorting=none]{biblatex}
\usepackage{graphicx}
\usepackage[margin=2cm]{caption}
%\usepackage[catalan]{babel}
\usepackage{float}
\usepackage{wasysym}
\usepackage{pifont}
\onehalfspacing
\usepackage[top=0.79in, bottom=0.79in, left=1.18in, right=0.79in]{geometry}
\renewcommand{\thefootnote}{\arabic{footnote}}
\addbibresource{bib.bib}
\begin{document}
[...]
\printbibliography
\end{document}

Result: enter image description here

8

The problem comes from csquotes. Either set the quoting style on loading, via

 \usepackage[style=english]{csquotes}

or if this is only a problem in the bibliography itself, issue

\setquotestyle{english}

just before \printbibliography.

Sample output

\documentclass[12pt,a4paper]{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[style=english]{csquotes}
\usepackage[backend=bibtex,sorting=none]{biblatex}
\usepackage[catalan]{babel}

\begin{filecontents}{\jobname.bib}
@Article{test,
  author =   {Author, A. N.},
  title =    {Title},
  journaltitle = {J. J.},
  year =     2000,
  volume =   15,
  number =   1,
  pages =    {4-8}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\nocite{*}
\printbibliography

\end{document}

Note that it would be better style to load babel before both csquotes and biblatex. Both these packages will use the options passed to babel when possible. Unfortunately csquotes doesn't know catalan, yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.