3

I'm trying to update to a newer version of pgfplots, preferably v1.12. I'm currently using v1.7.

First, I opened Update (admin mode) with MikTeX and it didn't have any updates for pgfplots. Then I downloaded the folder from CTAN for v1.12 and followed the instructions in the manual: opened Settings (admin mode), went to Root, added unzipped folder, moved it to the top (it was the only thing listed), applied.

\pgfplotsversion still listed 1.7.

Then opened the Package Manager (admin mode), changed repositories, synced, installed pgfplots and pgf (both listed as being updated in 2014).

\pgfplotsversion STILL lists 1.7 being used.

What else can I try or what am I doing wrong?

Edit: When I check the "Show MikTeX-maintained root directories" box, I see two other things. Is it a problem that I can't move my option up before one of them? See picture.

enter image description here

  • 2
    Try checking for updates in the non-admin Updates area. Depending on how/where the package was originally installed, it may show up here instead. – Paul Gessler Feb 14 '15 at 21:33
  • Did you download pgfplots.**tds**.zip. You should create a LocalTeXMF directory, register it via MiKTeX Options, and unzip the file there, and finally refresh the FNDB. – Bernard Feb 14 '15 at 22:47
  • Wow, that worked, thanks @PaulGessler! The non-admin Update found some stuff to update/remove(?), and after updating it now prints out 1.12. =) i.imgur.com/HpyA4hL.png <- screenshot of updates found – Hanmyo Feb 14 '15 at 22:48
6

If the package was originally installed "on-the-fly" or by using the user-mode Package Manager, its updates will appear only in the user-mode Update tool.

Only packages installed using the admin-mode Package Manager will appear in the admin-mode Update tool. I've now switched to TeX Live, but back in my MikTeX days I would always be sure to check for updates using both tools to get all possible new versions.

  • If this is a dupe of a more general question, feel free to vote as such. I searched for one but couldn't find anything. – Paul Gessler Feb 14 '15 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.