1

Following up on this question, I have the MWE example below, that works well except for when I want to print the resulting pdf, which becomes completely shrunk ... so small that I cannot read the letters. I cannot hand this in!

What is the problem here? I have tried every possibility, as you can see in the MWE (not specifying the A4 paper, using letterpaper instead, play with margins in cm and inches...)

This is the MWE:

\documentclass[handout, ignorenonframetext, xcolor={dvipsnames,table}]{beamer}
\usepackage{etex}
\reserveinserts{28}
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[]
%\pgfpagesuselayout{2 on 1}[a4paper]
%\pgfpagesuselayout{2 on 1}[letterpaper]
%\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
%\pgfpagesuselayout{2 on 1}[letterpaper,border shrink=0.5in]
\setbeameroption{show notes on second screen=bottom} % Beamer manual, section 19.3
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\setbeamercolor{background canvas}{bg=pink}

\usepackage{lmodern}

\setbeamertemplate{note page}[plain] % Beamer manual, section 19.1
\newlength{\parskipbackup}
\setlength{\parskipbackup}{\parskip}
\newlength{\parindentbackup}
\setlength{\parindentbackup}{\parindent}
\newcommand{\baselinestretchbackup}{\baselinestretch}

\usetemplatenote{

  %\insertslideintonotes{0.3}%

  \rmfamily \scriptsize%
  \setlength{\parindent}{1em} \setlength{\parskip}{1ex}%
  \renewcommand{\baselinestretch}{1}%

  \insertnote%

  \setlength{\parskip}{\parskipbackup}%
  \setlength{\parindent}{\parindentbackup}%
  \renewcommand{\baselinestretch}{\baselinestretchbackup}%
}



\begin{document}


\begin{frame}
Title slide
\note{this is a note}
\end{frame}

\begin{frame}
This is the first slide
\note{this is another note}
\end{frame}

\end{document}

The pdf produced looks flawless on screen:

flawless on screen

But look at the print preview (which is printed in the same way)... and this happens with every program I have tried, in both Ubuntu and Windows (Acrobat included), so it's a LaTeX problem...

shrunk print preview

Please help!

Note I want both the pdf on screen and when printed to look as it should... I don't want to enlarge the pdf on screen so it is printed correctly...

  • please consider accepting the answer, if it has solved the problem (in my case, it had ;) – Alessandro Cuttin Apr 14 at 10:55
2

I guess, this can be solved by applying appropriate printing properties. For example in Adobe Reader select the Fit option and it prints nicely.

enter image description here


EDIT:

For Okular, try the Trim Margins option.

enter image description here

  • Do you know of any program that can do the same in Ubuntu? Okular doesn't seem to be able to do so... In any case, shouldn't the actual size be the correct one, since I specify a4paper in the latex script? – DaniCee Feb 15 '15 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.