4

I have a problem with arscalssica style in combination with classicthesis.

The text under the chapter title starts always at the same position, independently on how long is the chapter title, which produce this ugly behaviour: enter image description here

The code I used to generete this output is really basic:

\documentclass[10pt,a4paper,twoside,openright,titlepage,fleqn,headinclude,footinclude,BCOR5mm,numbers=noenddot,cleardoublepage=empty,tablecaptionabove]{scrreprt}
\usepackage{subfig}
\usepackage[eulerchapternumbers,subfig,beramono,eulermath,pdfspacing]{classicthesis}

\usepackage{arsclassica}

\usepackage{blindtext}

\begin{document}
    \chapter{\blindtext}
    \blindtext
\end{document}

The compilation raises the following warnings:

C:\Program Files (x86)\MiKTeX 2.9\tex\latex\koma-script\scrreprt.cls: Class scrreprt Warning: You've used obsolete option `tablecaptionabove'.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\classicthesis\classicthesis.sty: Class scrreprt Warning: Usage of package `titlesec' together(scrreprt)              with a KOMA-Script class is not recommended.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\titlesec\titlesec.sty: Package titlesec Warning: Non standard sectioning command detected(titlesec)                Using default spacing and no format.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\titlesec\titlesec.sty: Package titlesec Warning: Non standard sectioning command detected(titlesec)                Using default spacing and no format.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\titlesec\titlesec.sty: Package titlesec Warning: Non standard sectioning command detected(titlesec)                Using default spacing and no format.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\titlesec\titlesec.sty: Package titlesec Warning: Non standard sectioning command detected(titlesec)                Using default spacing and no format.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\titlesec\titlesec.sty: Package titlesec Warning: Non standard sectioning command detected(titlesec)                Using default spacing and no format.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\classicthesis\classicthesis.sty:373: Package scrreprt Warning: Activating an ugly workaround for a missing(scrreprt)                feature of package `titlesec` on input line 373.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\arsclassica\arsclassica.sty:192: Package hyperref Warning: Option `hyperfootnotes' has already been used,(hyperref)                setting the option has no effect on input line 192.
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\arsclassica\arsclassica.sty:192: Package hyperref Warning: Option `pdfpagelabels' has already been used,(hyperref)                setting the option has no effect on input line 192

The behaviour is ok if I do not use arsclassica but only classicthesis: enter image description here

  • Very good example. – Johannes_B Feb 15 '15 at 10:05
  • 2
    \chapter{\blindtext} -- Do you mean this seriously? ;-) – user31729 Feb 15 '15 at 10:13
  • It is just an example, but it should work anyway. In my thesis I have quite long chapters titles, not so long of course, but three lines yes :-D – mrk_brn Feb 15 '15 at 10:17
  • If you are interested, we have been chatting a bit about it chat.stackexchange.com/transcript/message/20070403#20070403 – Johannes_B Feb 15 '15 at 10:40
  • \renewcommand{\formatchapter}{\raggedright} – Johannes_B Feb 15 '15 at 10:44
4

Try redefining the command \formatchapter in this way:

\renewcommand\formatchapter[1]{%
    \setbox0=\hbox{\chapterNumber\thechapter\hspace{10pt}\vline\ }%
    \begin{minipage}[t]{\dimexpr\linewidth-\wd0\relax}%
    \raggedright\spacedallcaps{#1}%
    \end{minipage}%
}

MWE:

\documentclass[10pt,a4paper,twoside,openright,titlepage,fleqn,headinclude,footinclude,BCOR5mm,numbers=noenddot,cleardoublepage=empty,tablecaptionabove]{scrreprt}
\usepackage{subfig}
\usepackage[eulerchapternumbers,subfig,beramono,eulermath,pdfspacing]{classicthesis}

\usepackage{arsclassica}

\renewcommand\formatchapter[1]{%
    \setbox0=\hbox{\chapterNumber\thechapter\hspace{10pt}\vline\ }%
    \begin{minipage}[t]{\dimexpr\linewidth-\wd0\relax}%
    \raggedright\spacedallcaps{#1}%
    \end{minipage}%
}

\usepackage{blindtext}

\begin{document}
    \chapter{\blindtext}
    \blindtext
\end{document} 

Output:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.