7

I am trying to run the following code through XeLaTeX, using the -shell-escape option:

\documentclass{article}
\usepackage{minted}

\begin{document}
\end{document}

The file is named guess.tex and the error I get is:

! Package catchfile Error: File `guess.w18' not found.

See the catchfile package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.93     \CatchFileDef\@tempa{\ip@file}{}

If I remove \usepackage{minted} it runs fine.

I am using ubuntu 14.04 and I have tried this both with the texlive version in the ubuntu repositories and with texlive 2014 (through the net installer). My version of pygments is 2.0.2.

  • Are you using the TeXlive version from the official Ubuntu repository? – Sigur Feb 18 '15 at 13:56
  • Yes, this is why I mentioned purging. I will edit my post. – odysseas Feb 18 '15 at 15:47
  • 1
    If you are going to use the most newer tools from the TeX world I recommend you to install TeXlive from its website not from the repository. – Sigur Feb 18 '15 at 15:48
  • Thanks, I will try going that way too. I am just wondering if anyone can reproduce the problem with this minimal example I have provided. It is striking to me that I do not actually _use minted code, I simply include the package. – odysseas Feb 18 '15 at 15:52
  • I have now downloaded and installed texlive 2014 using the net installer (instructions from [askubuntu.com/questions/486170/…). It still results in an identical error. This seems very odd to me, the input file is as minimal as it gets, it simply includes the minted package. – odysseas Feb 18 '15 at 19:24
4

It seems that I am facing exactly the same problem. It does not make any sense for me. However, it only worked for me when I removed the spaces from the name of tex file. The original name had some spaces like this "programming language.tex" and I transformed into "programing.tex.

Why I tried this?

I tried to execute

pdflatex -shell-escape programing language.tex

and it complained about finding "programming". So I tried this and it worked.

I am using Ubuntu 14.04 and kile as a tex editor.

1

I've just had a similar problem, and got rid of it by merely closing the command line (I use it to compile my documents), opening another one, doing a clean and recompiling everything.

If you use an editor provided with a compile option, try closing and re-opening it.

EDIT: A temporary solution I found was to reboot the computer when encountering such an error, but it's pretty strange indeed.

  • Do you experience the same problems when using pdflatex --shell-escape instead of xelatex --shell-escape? With pdflatex it seems it works. – logo_writer Sep 20 '15 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.