0

This question already has an answer here:

After noticing some compiling problems I ran Tex Live Utility 2014 and sure enough there was a problem.

It says "there are 520 packages available for update. Of these, the TeX Live installer packages listed here must updated first." The file is texlive.infra. After attempting an update the message comes as "the update failed." The log provides the following hints:

"tlmgr needs to be updated" tried doing that in terminal but it says I need administrator rights. Well, I am the owner so I was wondering how I can complete the step. Any other ideas?

marked as duplicate by egreg, user31729, diabonas, Mensch, Henri Menke Feb 19 '15 at 22:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 4
    Run in a terminal tlmgr update --self --all . – Gonzalo Medina Feb 19 '15 at 21:44
  • Depending on the system, you need to run it as administrator or sudo or whatever your OS is providing for that task. – Johannes_B Feb 19 '15 at 21:57
  • This is what I got: Nhaps-MacBook-Pro:~ Nhaps$ tlmgr update --self --all tlmgr: package repository mirror.utexas.edu/ctan/systems/texlive/tlnet You don't have permission to change the installation in any way, specifically, the directory /usr/local/texlive/2014/tlpkg/ is not writable. Please run this program as administrator, or contact your local admin.Nhaps-MacBook-Pro:~ Nhaps$ – Nhaps Feb 19 '15 at 21:57
  • 1
    @Nhaps sudo tlmgr update --self should do. The system will ask for the administrator password. – egreg Feb 19 '15 at 21:58
  • Thanks @egreg. I got this result: "...done running mktexlsr. running mtxrun --generate ... done running mtxrun --generate." TexLive is working again. – Nhaps Feb 19 '15 at 22:05

Browse other questions tagged or ask your own question.