2

My .tex files use textencoding latin1. For some practical reason I wanted to switch my bibliography .bib files to UTF8.

I tried that and (as the bibliography now was not typeset correctly) found the parameter bibencoding in biblatex which should do the trick. It did, but at the same time all my letters "ß" suddenly were replaced by "SS" in my pdf file.

You can see, that in the following example (at least in my pdflatex output)

  • I get "SS" instead of the "ß" letter. If, however, I remove the bibencoding=utf8 parameter, it is typeset correctly.
  • however, other special characters like ä ö ü are ok (also with the bibencoding parameter!)

Is this a bug? Can I do something to avoid it?

Example:

\documentclass{scrbook}


\usepackage[UKenglish, ngerman]{babel} %Sprachpakete Brit. Englisch, Deutsch Neue Rechtschreibung
\usepackage[latin1]{inputenc}
\usepackage[TS1, T1]{fontenc} %Kodierungen für Text 1 und Text Symbols

    \begin{filecontents*}{mybib7.bib}

    @MISC{Caesar,
      author = {Caesar, Gaius J.},
      title = {title},
      year = {45BC},
    }

    @MISC{Cicero,
      author = {Cicero, Marcus T.},
      title = {title},
      year = {44BC},
    }

    \end{filecontents*}

    \newcommand{\WW}{\textsuperscript{*}}

    \usepackage[natbib=true, style=numeric-comp, backend=bibtex8, bibencoding=utf8, defernumbers, useprefix, maxnames=99, maxcitenames=3]{biblatex}  % f¸r bessere Literaturverzeichnisse
    \renewcommand{\bibfont}{\normalfont\small}
    \renewcommand\multicitedelim{\addsemicolon\space}


    \usepackage{csquotes} 

    \bibliography{mybib7}

    \begin{document}



This is a test, if the letter ß is displayed correctly.

ä ö ü are ok!



    \nocite{*}
    \printbibliography

    \end{document}

Result in pdflatex

enter image description here

  • 7
    The biblatex manual specifically says that you cannot use a UTF-8 bibencoding with BibTeX(8): the fact that odd things then happen could well be regarded as this simply being an undefined case. – Joseph Wright Feb 20 '15 at 11:28
  • 5
    To follow up on Joseph Wright's comment, you need to use biber as the backend for such a set-up. – Andrew Swann Feb 20 '15 at 11:37
  • @AndrewSwann: thanks a lot. I just discovered that myself. If you post it as an answer, I can accept it and close this case. :-) – MostlyHarmless Feb 20 '15 at 11:43
  • .... but still it's confusing for me that a parameter of the bibliography process can mess up my normal text which has nothing to do at all with the bibliography... – MostlyHarmless Feb 20 '15 at 11:43
  • 6
    biblatex reads the bibliographic data at the begin of the document and so has to change the inputencoding there. In the case of utf8 (which isn't recommended for bibtex8 anyway) it doesn't seem to reset it correctly. You could try \inputencoding{latin1} after \begin{document}. – Ulrike Fischer Feb 20 '15 at 11:53
0

As stated by Andrew Swann in his comment above (thanks a lot!), biber is necessary as backend if UTF-8 is used, so the solution is the option

backend=biber

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.