1

I started typing in a latex template provided by my school. Inside the document, when I use special characters such as accents or umlauts (e.g. ë) they encode just fine. When I use an external file (\input{file}) it also encodes perfectly. I use \usepackage[latin1]{inputenc} in my main document.

But the document also imports an abstract.tex file using:

\abstractpagetrue
\abstracts{abstract}

And in that file, I also have a lot of ë characters and they encode to ë. That tex file only contains some raw text with no latex commands whatsoever.

Does anyone have an idea how to fix this?

  • 3
    the file with the ë is almost certainly encoded in UTF-8 not latin1. Make sure that your editor is set to encode all the files in the same encoding, this can be UTF-8 or latin-1 but then you need the appropriate option to inputenc – David Carlisle Feb 21 '15 at 17:06
  • Thank you. I didn't check the settings of the editor itself, only the latex settings. The editor was set to UTF-8. I changed it and now it encodes just right! Thanks! – JSS Feb 21 '15 at 17:29
  • @DavidCarlisle ^ – Johannes_B Feb 23 '15 at 20:50
2

The file with the ë is almost certainly encoded in UTF-8 not latin1.

Make sure that your editor is set to encode all the files in the same encoding, this can be UTF-8 or latin-1 but then you need the appropriate option to inputenc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.