4

I'm using Texmaker with biber. Everything works great, all references and the bibliography work as intended.
When I want to reference, I say \cite and get a list of suggestions, starting with \citep{...}.
I personally don't see any benefits in using \citep instead of just \cite, I even get an error Undefined control sequence \citep when trying to use \citep.
As the suggestion list starts with \citep, I have to scroll down through all my possible references, until I reach \cite{...}.

Is it possible, to disable \citep, so that my list starts directly with just \cite?

I know, it's first world problem, but nevertheless it would save me some time.

3
  • 1
    I can't see any way to do this. I can just suggest to use a shortcuts options -> configure texmaker -> shortcuts and find down \cite{}
    – touhami
    Commented Feb 21, 2015 at 22:50
  • 1
    If you add natbib=true to biblatex' options you can use \citep and \citet, but they only make sense with author-year citations of course. (The corresponding 'native' biblatex commands are \parencite and \textcite.) Also, as your question is actually just a question about Texmaker I'll retag it. Commented Feb 21, 2015 at 23:27
  • Have you considered using \autocite? It offers additional flexibility and would presumably make the top of the list of suggestions. (Why is \citep above \cite, though? Why not alphabetical order?)
    – cfr
    Commented Feb 22, 2015 at 2:07

1 Answer 1

3

There does not seem to be a way to disable the \citep suggestion in Texmaker, but I circumvent the trouble by adding this in the document header:

\newcommand{\citep}[1]{\cite{#1}}

This actually defines the control sequence \citep. All it does is to translate \citep into \cite, which compiles just fine.

As a result, you can use the suggestions in the \citep list and do not have to scroll all the way down.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .