0

I have a figure in which i have labelled axes manually.

\begin{figure}[H]
 \centering
\setlength{\unitlength}{0.1\textwidth}
\begin{picture}(5,3.5)

 \put(-0.1,0.1){$0$}
  \put(-0.1,3){$1$}
 \put(-1.0,1.55){$S(T)$}
  \put(0.13,-0.2){$0$}
   \put(4.90,-0.2){$T$}

 \put(2.5,-0.5){$t$}
 \put(0,0){\includegraphics[width=0.50\textwidth]{switchmod.eps}}
\end{picture}
\caption{Switch model}
 \label{fig:lion}
\end{figure}

And the output is enter image description here

As clear from picture, figure caption and my manual labeling have been overlapped. How to create space such that caption is much lower?

  • Adjust the pictures size and offset. (5,3.5) in your code now. – Paul Gessler Feb 23 '15 at 15:58
  • 2
    Or consider using the tikz package instead of the picture env. Then the sizes are automatically adjusted. – daleif Feb 23 '15 at 15:59
  • @Paul adjusting picture size and offset did not help as it was dealing picture as a whole. Means shifting the whole picture with labels up , down or left, right. I need to the option such that caption is much lower. How to specify the position? – zenith Feb 23 '15 at 16:02
  • You can use the second () optional argunment of picture to allow for your negative coordinates, but simpler is just leave a blank line after the picture and put \vspace{5cm} before the caption – David Carlisle Feb 23 '15 at 16:08
  • used \vspace{5cm} . It worked. Thank you – zenith Feb 23 '15 at 16:10
1

You can use the second () optional argument of picture to allow for your negative coordinates, but simpler is just leave a blank line after the picture and put

\vspace{5cm} 

before the caption

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.