6

I have the following:

\usepackage{fontspec}
\setromanfont [Ligatures={Common}, Numbers={OldStyle}]{Palatino}

And compile with this:

xelatex main.tex

I use:

``word''

But the quotes are never curly as they should be. I can only get the curly quotes when using the default font.

Ideas?

2 Answers 2

13

You need to use the option Ligatures=TeX (or Mapping=tex-text for older version of fontspec), e.g.:

\setmainfont [Ligatures={Common,TeX}, Numbers={OldStyle}]{Palatino}
10
0

I found a useful fix at the link below, after many hours of searching:

https://github.com/jgm/pandoc/issues/889

Basically change

\setmonofont[]{$monofont$}

to

\setmonofont[Mapping=tex-ansi]{$monofont$}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .