8

I have the following command in my preamble:

\documentclass[letterpaper,twoside,openright]{book}

But \chapter{}s still start on the left. I have seen this thread and this thread but the solutions didn't fix it for me.

  • 1
    Works for me. (Note that the right pages are the odd numbered pages, contrary to what Adobe displays by default.) – Caramdir Jul 14 '11 at 2:17
  • Which is the bigger margin, inner or outer? – Honza Pokorny Jul 14 '11 at 2:21
  • by default the outer margin – Caramdir Jul 14 '11 at 2:24
13

The book class uses by default the openright option. This can be easily checked by looking at the page numbers, which are odd for right pages.

Someone may be disconcerted by the fact that the outer margin is wider than the inner one; this choice agrees with the vast majority of fine quality books. When a book is spread open, two inner margins are side by side, summing up their lengths. Moreover, readers can use the outer margin for their annotations.(*)

All good PDF viewers have the option to look at a spread ("Two-Up" is called in Adobe Reader) and to separate the first page ("Show cover page during Two-Up" in Adobe Reader).

(*) Cuius rei demonstrationem mirabilem sane detexi hanc marginis exiguitas non caperet. (Pierre de Fermat)

  • 1
    I still have a problem. I have \documentclass[a4paper,twoside,openright,final,12pt]{book} and all chapters begin on the left (even numbered) page (my adobe acrobat has default 'two up (cover mode)'). If I change openright to openleft, there is absolutely no effect, but if I change it to openany, then it does have effect. I would just like to have chapters start on the right (odd numbered) pages. Please help. – Leon Sep 10 '12 at 20:37
  • @LeonLampret This seems quite bizarre. Without an example of code I wouldn't believe it. :) – egreg Sep 10 '12 at 20:52
  • When I was constructing a MWE, I found out that my code was containing \makeatletter \renewcommand*\cleardoublepage{\clearpage\if@twoside \ifodd\c@page \hbox{}\newpage\if@twocolumn\hbox{} \newpage\fi\fi\fi} \makeatother, which was the cause of all my problems. Previously I wanted the chapters to start on the left, but later I forgot what that code was even for. Sorry. Now, the problem is solved. Thanks! – Leon Sep 10 '12 at 21:26
  • @LeonLampret This is openleft! Of course you got that behavior! :-) – egreg Sep 10 '12 at 21:28
1

This thread and this thread helped me to understand better how the geometry package works and helped me fix my issue, which if I understood correctly, it was similar to what you describe.

In my case, I used a combination of the solution in both threads and put in my preamble this:

\setlength{\marginparwidth}{0pt}
\let\tmp\oddsidemargin
\let\oddsidemargin\evensidemargin
\let\evensidemargin\tmp
\reversemarginpar

I know it is not the most elegant solution, but it worked for me. Hope it helps.

  • after six year :-), sorry, i doubt for OP :-(. but this is simply accomplish with geometry packages using option inner=... and outer=... and of course \documentclass[twoside]{book}. welcome to tex.se – Zarko Aug 17 '17 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.