2

I use LyX with biblatex 2.9a, biber 1.9 and the authoryear-comp style. My biblatex configuration is below:

\usepackage[backend=biber,style=authoryear-comp,natbib=true]{biblatex}

When I insert two citations from the same authors and years (this is \citet{author2014a,author2014b} in the source code panel), I want LyX / LaTeX to produce

Author (2014a, b)

At least, this is what I guess should be returned from the authoryear-comp style. Instead, I get

Author (2014a), b

I get the same result when I insert the following LaTeX code as ERT: \textcite{author2014a,author2014b}.

Any ideas how to solve this problem?

closed as off-topic by moewe, Martin Schröder, user31729, egreg, Mico Mar 30 '15 at 10:21

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Which biblatex and biber version? – Ulrike Fischer Feb 26 '15 at 15:05
  • 1
    When I was trying to build a MWE I figured out where the problem came from. Earlier, I added some code in order to define the authors' names as hyperlinks as well (copied from somewhere). Outcommenting these lines leads to the desired citation result and I can live without hyperlinked names. – der_grund Mar 3 '15 at 9:45
  • 1
    @MatthiasGomolka Would you like to add an answer, or should we close this question? – Torbjørn T. Mar 29 '15 at 8:39
  • 1
    Closing the question would be best. – der_grund Mar 30 '15 at 8:15
  • 5
    I'm voting to close this question as off-topic because it is about a problem that is not in the question (additional code modifying the behaviour of cite commands) and has since been resolved by the OP themselves (see comments above). – moewe Mar 30 '15 at 9:01
0

From the lyx wiki

To change from bibtex to biber, go toLyX→Preferences→Settings→Output→LaTeX and change the bibtex commandfrom bibtex to biber (you can also input biber options, if you need them). Also note that you should pass the option backend=biber (instead ofbackend=bibtex) to the \usepackage[...]{biblatex} call if you use biber, although this is not strictly necessary anymore in recent biblatex releases which default to biber if you do not pass the backend option at all.

  • I am not sure how this answers the OPs question. Apparently, he is already (and successfully) using LyX with biblatex and biber, but has an issue regarding the resulting citation style. – Daniel Feb 27 '15 at 9:19
  • This is true. Apart from the rather small problem that I desdribed above, biblatex, biber and LyX work fine. I followed the instructions from the LyX Wiki. – der_grund Feb 27 '15 at 10:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.