4

I'm trying to make a citation to an IPCC technical summary and want to include all authors in the bibliography entry. I also want to use APA-style citations for the paper. These two settings seem to conflict. A MWE with the options required for APA-style citation commented out is included below. How can I make the citation appear in APA-style but still including all authors in the bibliography entry?

\begin{filecontents*}{\jobname.bib}
@book{ipcc_tech_2013,
    author = {T.F. Stocker and D. Qin and G.-K. Plattner and L.V. Alexander and S.K. Allen and N.L. Bindoff and F.-M. Bréon and J.A. Church and U. Cubasch and S. Emori and P. Forster and P. Friedlingstein and N. Gillett and J.M. Gregory and D.L. Hartmann and E. Jansen and B. Kirtman and R. Knutti and K. Krishna Kumar and P. Lemke and J. Marotzke and V. Masson-Delmotte and G.A. Meehl and I.I. Mokhov and S. Piao and V. Ramaswamy and D. Randall and M. Rhein and M. Rojas and C. Sabine and D. Shindell and L.D. Talley and D.G. Vaughan and S.-P. Xie},
    year = {2013},
    title = {{Technical Summary. I Climate Change 2013: The Physical Science Basis. Contribution of Working Group I to the Fifth Assessment Report of the Intergovernmental Panel on Climate Change}},
    editor = {T.F. Stocker and D. Qin and G.-K. Plattner and M. Tignor and S.K. Allen and J. Boschung and A. Nauels and Y. Xia and V. Bex and P.M. Midgley},
    publisher = {Cambridge University Press},
    address = {Cambridge, United Kingdom and New York, NY, USA},
}}
\end{filecontents*}

\documentclass[a4paper,12pt]{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[swedish]{babel}
\usepackage{csquotes}

\usepackage[
    bibstyle=authortitle,
    citestyle=authoryear,
    maxcitenames=5,
    mincitenames=3,
    maxbibnames=1000,
    backend=biber,
    date=short,
    sorting=nyt,
    %style=apa
]{biblatex}
\addbibresource{\jobname.bib}
%\DeclareLanguageMapping{swedish}{swedish-apa}

\begin{document}

A citation: \cite{ipcc_tech_2013}

\printbibliography

\end{document}
4

Since biblatex-apa aims to comply exactly with the slightly complicated APA guidelines, the "standard" options maxnames and friends do not work (as expected, if at all) with biblatex-apa.

To include an arbitrary number of authors (and editors) in the bibliography is possible though with the option apamaxprtauth, which defaults to 7, see §3.1 Package options, p. 5 of the biblatex-apa documentation. In this case we just set it to 999 and everything works fine.

MWE

\documentclass[a4paper,12pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[swedish]{babel}
\usepackage{csquotes}
\usepackage{filecontents}

\begin{filecontents*}{\jobname.bib}
@book{ipcc_tech_2013,
    author = {T.F. Stocker and D. Qin and G.-K. Plattner and L.V. Alexander and S.K. Allen and N.L. Bindoff and F.-M. Bréon and J.A. Church and U. Cubasch and S. Emori and P. Forster and P. Friedlingstein and N. Gillett and J.M. Gregory and D.L. Hartmann and E. Jansen and B. Kirtman and R. Knutti and K. Krishna Kumar and P. Lemke and J. Marotzke and V. Masson-Delmotte and G.A. Meehl and I.I. Mokhov and S. Piao and V. Ramaswamy and D. Randall and M. Rhein and M. Rojas and C. Sabine and D. Shindell and L.D. Talley and D.G. Vaughan and S.-P. Xie},
    year = {2013},
    title = {{Technical Summary. I Climate Change 2013: The Physical Science Basis. Contribution of Working Group I to the Fifth Assessment Report of the Intergovernmental Panel on Climate Change}},
    editor = {T.F. Stocker and D. Qin and G.-K. Plattner and M. Tignor and S.K. Allen and J. Boschung and A. Nauels and Y. Xia and V. Bex and P.M. Midgley},
    publisher = {Cambridge University Press},
    address = {Cambridge, United Kingdom and New York, NY, USA},
}}
\end{filecontents*}

\usepackage[
    backend=biber,
    date=short,
    sorting=nyt,
    style=apa,
    apamaxprtauth=999,
]{biblatex}
\addbibresource{\jobname.bib}
\DeclareLanguageMapping{swedish}{swedish-apa}

\begin{document}

A citation: \cite{ipcc_tech_2013}

\printbibliography

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.