1

I am creating derivative work of classic thesis template from Andre Miede (http://www.miede.de/index.php?page=classicthesis). What I have done was adding option for slovak language into the document class like this:

\documentclass[twoside,openright,titlepage,numbers=noenddot,headinclude,%1headlines,% letterpaper a4paper
        footinclude=true,cleardoublepage=empty,abstractoff, % <--- obsolete, remove (todo)
        BCOR=5mm,paper=a4,fontsize=11pt,%11pt,a4paper,%
        ngerman,american,slovak%
        ]{scrreprt}

This is excerpt of error message I get when trying to compile the source file:

Package natbib Warning: Citation `knuth:1974' on page xi undefined on input lin
e 11.


Package natbib Warning: Citation `knuth:1974' on page xi undefined on input lin
e 11.

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\eulervm\uzeur.fd")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\microtype\mt-eur.cfg")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\eulervm\uzeus.fd")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\microtype\mt-eus.cfg")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\eulervm\uzeuex.fd")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\psnfss\ot1zplm.fd")
Overfull \hbox (2.84056pt too wide) in paragraph at lines 27--36
[]\T1/pplj/m/n/10.95 Regarding the ty-pog-raphy and ot-her help, many thanks go
 to Marco
) [11] [12] (FrontBackmatter/Contents.tex (ChinesePoets.toc) [13]
(ChinesePoets.lof) (ChinesePoets.lot) (ChinesePoets.lol) [14]) [1] [2]
(Chapters/Chapter01.tex
Kapitola 1.
! Missing $ inserted.
<inserted text> 
                $
l.7     Master'
               s
? 

This is relevant part of source file Chapter01.tex:

\begin{enumerate}
    \item Provide students with an easy-to-use template for their
    Master's
    or PhD thesis. (Though it might also be used by other types of
    authors
    for reports, books, etc.)
    \item Provide a classic, high-quality typographic style that is
    inspired by \citeauthor{bringhurst:2002}'s ``\emph{The Elements of
    Typographic Style}'' \citep{bringhurst:2002}.
    \marginpar{\myTitle \myVersion}
\end{enumerate}

It seems like the LaTex compiler has problem with apostrophe character '. Why is this happening ? Please explain it in simple way because most of my life I have used tools like Word and OpenOffice Writer. I have minimal experiences with TeX systems. Just recently finished reading introductory book into LaTeX system.

P.S. The problem can be reproduced on this simple document:

\documentclass[ twoside,openright,titlepage,numbers=noenddot,headinclude,%1headlines,% letterpaper a4paper
                footinclude=true,cleardoublepage=empty,abstractoff, % <--- obsolete, remove (todo)
                BCOR=5mm,paper=a4,fontsize=11pt,%11pt,a4paper,%
                ngerman,american,slovak%
                ]{scrreprt}

%********************************************************************
% Note: Make all your adjustments in here
%*******************************************************
\input{classicthesis-config}

%********************************************************************
% Hyphenation
%*******************************************************
%\hyphenation{put special hyphenation here}

% ********************************************************************
% GO!GO!GO! MOVE IT!
%*******************************************************
\begin{document}
\frenchspacing
\raggedbottom
%\renewcommand*{\bibname}{new name}
%\setbibpreamble{}
\pagenumbering{roman}
\pagestyle{plain}
%********************************************************************
% Frontmatter
%*******************************************************

%************************************************
\chapter{Introduction}\label{ch:introduction}
%************************************************
This bundle for \LaTeX\ has two goals:
\begin{enumerate}
    \item Provide students with an easy-to-use template for their
    Master's
    or PhD thesis. (Though it might also be used by other types of
    authors
    for reports, books, etc.)
    \item Provide a classic, high-quality typographic style that is
    inspired by \citeauthor{bringhurst:2002}'s ``\emph{The Elements of
    Typographic Style}'' \citep{bringhurst:2002}.
    \marginpar{\myTitle \myVersion}
\end{enumerate}
\end{document}
14
  • 2
    Please always post a document that reproduces the error, I tried to construct a document from the preamble and enumerate that you posted but just get LaTeX Warning: Unused global option(s): [ngerman,american,slovak]. No file ff500.aux. ! Undefined control sequence. l.15 inspired by \citeauthor Feb 28, 2015 at 15:32
  • You do know that this simple document is a lump of mostly unneded code, right?
    – Johannes_B
    Feb 28, 2015 at 15:39
  • Sorry but I didnt know on beginning where is the source of problem. The ClassicThesis template consists of 17 different files and I am not accustomed to error messages of TexWorks. Feb 28, 2015 at 15:40
  • 1
    Your example is now 500!!! lines long and still doesn't reproduce the error in the question ! LaTeX Error: File `classicthesis-config.tex' not found. Type X to quit or <RETURN> to proceed, or enter new name. (Default extension: tex) Enter file name: LaTeX Warning: Unused global option(s): [ngerman,american,slovak]. (./ff500.aux) Chapter 1. ! Undefined control sequence. l.82 inspired by \citeauthor Feb 28, 2015 at 15:43
  • 1
    @Mico As the hunter and destroyer of templates, i got it ;-)
    – Johannes_B
    Feb 28, 2015 at 15:57

1 Answer 1

4

Classicthesis does a mess, so does the config-file that is provided with the template bundlle. Simple advice, don't use it.

Simple solution to the stated problem is to load package classicthesis before loading the config file.

After reducing everything that is irrelevant for the stated problem, we come to the following.

\documentclass[slovak]{scrreprt}
\usepackage{babel}
\usepackage{eulervm}
\begin{document}
Master's
\end{document}

The slovak-option of babel seems to do strange stuff.
Load babel after setting the font, and everything is fine.

6
  • Unfortunetaly this solves only partially problem. The simplified example compiles correctly, but the real document not. I can't exclude possibility that its because of your workaround. Now I receive error "Undefined control sequence \ctparttext". Its really not that simple to simplify real complex example. There are too many variables included. Mar 1, 2015 at 6:25
  • It has to do with babel shorthands. If I disable them be defining command \usepackage[shorthands=off]{babel} problem disappears. It doesnt help to switch to english language before chapters written in english with command \selectlanguage{american}. The latex persists on using shorthands defined for slovak language. The solution would be to use english shorthands for english texts and slovak shorthands for slovak texts. Unfortunately I cannot find documentation with all the shorthands supported for particular language. Mar 1, 2015 at 11:06
  • If i take your example, load classicthesis before the config-file that comes with the template bundle, the error disappears. Please provide a minimal working example that reproduces the error for us. Everybody is encouraged to change the config file (which is quite useless to tell the truth). I cannot know what has been changed in yours.
    – Johannes_B
    Mar 1, 2015 at 13:59
  • After documentclass, do \usepackage{eulervm}.
    – Johannes_B
    Mar 1, 2015 at 14:06
  • After loading classicthesis on beginning of config-file as you suggested and with all the original options i.e. \PassOptionsToPackage{eulerchapternumbers,listings,drafting, pdfspacing,subfig,beramono,eulermath,parts}{classicthesis} \usepackage{classicthesis} all problems disappeared. I was not successfull at first try because I have not specified any of optional parameters to classicthesis package. Mar 2, 2015 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.