2

UPDATE: Solved. See my comment below for the fix.

I've been trying for the life of me to figure out how to use the math tikzlibrary (\usetikzlibrary{math}), and no code works. I fear that it has something to do with the pgf or tikz installation. I have tried to re-install the tikz package, and it's still not working. Could the math tikzlibrary be somewhere else?

I guess it's common here to post an example of nonworking code, so here's an example of what is not working:

\documentclass[tikz,border=0.125cm]{standalone}
\usetikzlibrary{math}
\begin{document}

\end{document}

The error output is:

! Package tikz Error: I did not find the tikz library 'math'. I looked for file
s named tikzlibrarymath.code.tex and pgflibrarymath.code.tex, but neither could
 be found in the current texmf trees..

See the tikz package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.2 \usetikzlibrary{math}

Thanks! EDIT: The question was posted as unclear, so here's a clarified version:

I was unable to use the tikz sublibraries (specifically the math library), even though I was able to use the regular tikz library (tikzpicture, etc). I was asking what could have caused this. In retrospect, my question could have been watered down to "How can I make sure that all of the tikz subpackages are present, and MikTex can access all of them?" or "How can I update tikz and which directory of the tikz package should I root to MikTex?"

closed as unclear what you're asking by egreg, user31729, Svend Tveskæg, Jesse, user13907 Mar 1 '15 at 11:31

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    What do you get if you run kpsewhich tikzlibrarymath.code.tex on a console? Also, where are you installing your packages from? – Gonzalo Medina Mar 1 '15 at 2:53
  • 1
    What is your TikZ/PGF version? The math library comes with TikZ/PGF 3.0. – Paul Gaborit Mar 1 '15 at 8:13
  • Aha! Victory! My mistake was that I didn't properly add the root directory! To all future visitors: if you are using MikTex on windows, here's what I did to solve the problem: 1) Download and unzip the above pdf/tikz package. 2) go to start -> programs -> MikTex 2.* -> Maintenance (Admin) -> Settings (Admin) and open the admin options. 3) Go to roots, and add the directory 'pgf_3.0.0.tds' To finalize, hit OK. 4) Package worked like a charm. Man, I should stop doing LaTeX things at 3:00am – Assaf Bar-Natan Mar 1 '15 at 9:13
  • 1
    Could you post your solution as an answer? That'll make it easier for others with the same problem to find the solution in the future – Jake Mar 1 '15 at 9:23
  • @AssafBar-Natan You don't need to install the TDS version. TikZ v3 is official on MikTeX just update your package with admin priviledges. – percusse Mar 1 '15 at 10:22

Browse other questions tagged or ask your own question.