29

I'm trying to compile myFile.tex, a program which draws on bibtex and biber

\documentclass[12pt]{article}
\usepackage{amsmath}
\usepackage[style=authoryear,backend=biber]{biblatex}
\addbibresource{myRefs.bib}
...
\begin{document}
...By the Seuss theorem\textcite{firstRef}
...
\section{References}
\printbibliography 
\end{document}

Upon compiling, this gave me the following errors

I found no \citation commands---while reading file myFile.aux
I found no \bibdata command---while reading file myFile.aux
I found no \bibstyle command---while reading file myFile.aux

I don't understand why this is happening, or what I have to do with myFile.aux. Can anyone explain this and how to get around it?

4
  • Hi! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – yo'
    Mar 2, 2015 at 14:23
  • 5
    You've asked for the Biber back-end and then are running BibTeX!
    – Joseph Wright
    Mar 2, 2015 at 14:23
  • Joseph, is that a problem? I'm sorry my newness is showing here.
    – Sammieo
    Mar 3, 2015 at 21:08
  • 3
    Yes, if you choose biber, you have to run biber.
    – MaxNoe
    Mar 3, 2015 at 23:01

3 Answers 3

23

As mentioned in the comments, you should run biber to compile your bib file as you have used biber as the backend.

\usepackage[style=authoryear,backend=biber]{biblatex}

Here are the commands to compile your myFile.tex and your .bib files:

pdflatex myFile
biber myFile
pdflatex myFile
1
4

I have the same problem with TeXstudio, and backend=biber does not work for me. If you're using TeXstudio too, you have two options:

  1. change the default bibliography tool in TeXstudio settings (Options > Configure TeXstudio > Build > Default Bibliography Tool)

  2. add this line at the beginning of the document

    % !BIB TS-program = biber

4
  • 6
    A possible third option (if things get rough) is to give up Give up biber backend and specify bibtex backend: backend=bibtex Oct 24, 2019 at 11:15
  • 3
    @loved.by.Jesus "Giving up is not an option."
    – rugk
    Jul 2, 2020 at 15:12
  • @loved.by.Jesus It worked. You should put it to answers Jul 18, 2022 at 10:48
  • @user3050590 Thanks for motivating; I put it to answers. It was just a thought line, and I am happy it helped someone. Be blessed! Jul 18, 2022 at 20:28
3

Quick fix:

Fall back on bibtex backend. Modify the option of the biblatex package.

backend=bibtex

In your example it would look like that:

\usepackage[style=authoryear,backend=bibtex]{biblatex}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .