1

I'm using Fedora 21 as OS and Texmaker to compile my tex files, recently I used minitoc package but I got always the same error !

! LaTeX Error: File `minitoc.sty' not found.

I tried to install the package using the following command, but it doesn't work !

$ su -c "yum install 'tex(minitoc.sty)'"

Thanks for your help to resolve this problem.

  • The files are on CTAN. – jon Mar 2 '15 at 20:04
  • 1
    Welcome to TeX.SX! I am sure that Fedora has no package named tex(minitoc.sty). Even without checking, such a name would violate any sanity-check whatsoever. – cfr Mar 3 '15 at 0:52
  • 1
    thanks for the comment, but usually it's the command I use to install the .sty package and it works very well ; but now I really can't use minitoc under the Fedora distribution. – Malek B. Mar 3 '15 at 15:08
  • Fedora 21 is end-of-life, time to upgrade – vonbrand Jan 18 '16 at 1:24
3

I'm using Fedora 22, I had the same problem and solved it by installing the texlive-collection-latexextra package.

$ sudo dnf install texlive-collection-latexextra

It seems that the most reliable way to be able to compile most tex files is to download all packages.

|improve this answer|||||
  • Thank you so much for your answer, I was looking for this a longtime ago. – Malek B. Nov 27 '15 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.