0

When running the result of the enclosed MWE (with AR) you will see that the commanded change in transition style does not take place in time. It will occur only after the change of the frame - and this is definitely too late: I like the final result of the first frame to stay on the display until I say 'move on'.

There are some similar questions in stackexchange but they do not deliver a solution as far as I can see. [Even Beamer - change transition style within a slide does not work for me, which is really surprising ...] Grateful for every help as always.

\documentclass{beamer}
\usepackage{tikz}
\newcommand{\TikZsetword}[2]{\visible<+->{\node at #2 {#1};}}
\begin{document}
\begin{frame}{foo}
\transduration{1}
\begin{tikzpicture}
 \TikZsetword{Rauschleistungsdichte}{(0,0)}
 \TikZsetword{Rauschtemperatur}{(1,1)}
 \TikZsetword{Rauschzahl}{(2,2)}
 \transreplace<3>
\end{tikzpicture}
\end{frame}
\transreplace
\begin{frame}{bar}
\begin{tikzpicture}
 test
\end{tikzpicture}
\end{frame}
\end{document}

Document Class: beamer 2015/01/05 3.34 A class for typesetting presentations

  • I'm not sure I follow what the issue is here. You've set \transduration as 1 second and I get auto-replacement of the slide content when I view in Adobe Reader at full screen (AR 11.0.10.32). What are you seeing? (\transreplace is the standard 'flip to the next page' transition.) – Joseph Wright Mar 3 '15 at 18:19
  • Sorry, yes, what I would like to get is: automagically (\transduration) switching through the first frame, but stopping at the third and last step in this frame (\transreplace). – Jürgen Mar 4 '15 at 6:00
1

You are misunderstanding the relationship between \transduration and \transreplace. The latter is about how a page should change, here a straight swap, ..., but says nothing about how long a page should last for. That is set by \transduration. In your example, the \transduration{1} applies to all of the first frame, so you get the expected auto-change until you start the second frame. What you therefore need to do is cancel the auto-changing:

\documentclass{beamer}
\usepackage{tikz}
\newcommand{\TikZsetword}[2]{\visible<+->{\node at #2 {#1};}}
\begin{document}
\begin{frame}{foo}
\transduration{1}
\begin{tikzpicture}
 \TikZsetword{Rauschleistungsdichte}{(0,0)}
 \TikZsetword{Rauschtemperatur}{(1,1)}
 \TikZsetword{Rauschzahl}{(2,2)}
 \transduration<3>{}
\end{tikzpicture}
\end{frame}
\begin{frame}{bar}
\begin{tikzpicture}
 \TikZsetword{Rauschleistungsdichte}{(0,0)}
 \TikZsetword{Rauschtemperatur}{(1,1)}
 \TikZsetword{Rauschzahl}{(2,2)}
\end{tikzpicture}
\end{frame}
\end{document}

Notice that I need to use an empty argument here: setting \transduration<3>{0} means 'as fast as possible'!

|improve this answer|||||
  • You are absolutely right: I did not get the correct meaning of the different \trans...-commands. With \transduration<+->{} in my target code I now obtain the required behaviour! Perhaps this section of the fine manual can be optimized? (BTW: all the \trans...-commands did not find the way into the index - beware, this should be no criticism, just a hint!) – Jürgen Mar 4 '15 at 7:53
  • I've added a note to the manual and fixed the lack of indexing of commands (in general!). – Joseph Wright Mar 4 '15 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.