99

My .bib files are generated by Mendley desktop and usually contain URLs, ISSN and DOIs, but I don't want those to be displayed in my list of references. How can I get rid of them (short of deleting those from the entries, I just want to not display them...) I am using biblatex.

109

Assuming you are using standard styles, use options doi=false,isbn=false,url=false. The manual describes these as 'style-specific' options, as they do depend on the bibliography style in use.

  • 2
    I know this is an old question, and I might ask a new one, but this appears to strip ISBN (useful for books) as well as ISSN (not so useful for journals. – Chris H Mar 20 '14 at 12:01
  • 1
    @ChrisH Would probably be a new question, but I've never seen a published bibliography giving ISBNs (depend on things like hard/soft backing as well as text itself). – Joseph Wright Mar 20 '14 at 12:07
  • 2
    I found another question answering precisely this at tex.stackexchange.com/q/40097/28808 which works for me. I take your point but I'm sure I've seen it in thesis bibliographies, and if you were to cite page numbers it would make sense, as a given numbered edition may not have the same pagination in all versions (considering international versions as well as bindings) – Chris H Mar 20 '14 at 13:53
  • 8
    Where exactly should i put these options? – MERose Jun 30 '16 at 8:44
  • 1
    Would be good to add MWE for this. – George Vousden Jul 23 '16 at 19:03
16

Alternatively, if you want biblatex not to see these fields at all, use Biber and see section 4.5.3 of the biblatex manual. You are now able to filter out arbitrary fields (and map them to other fields) before biblatex even sees the data with so-called source maps.

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=authoryear, backend=biber]{biblatex}

\DeclareSourcemap{
  \maps[datatype=bibtex]{
    \map{
      \step[fieldset=issn, null]
    }
  }
}

\addbibresource{biblatex-examples.bib}

\begin{document}
\cite{sarfraz}
\printbibliography
\end{document}
  • 1
    This is also very helpful to remove the abstract field, which quite often contains strange characters like % but will rarely ever be used in the bibliography. – matth Oct 28 '11 at 14:06
  • I tried to look it up, but with the current version 2.12 as of Feb. 2019 there is no section 2.1.1 anymore (have a look at the biber-manual at CTAN). There is a section 3.1.1 but I couldn't find a clear reference for the given problem there. – gr4nt3d Feb 25 at 11:52
  • The reference is to a very old version of biber. See section 4.5.3 of the current biblatex manual. – PLK Mar 17 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.