3

I've got a frame that first has some itemize text and then want to split it in two columns to have some more itemized text on each column.

The problem is I can't align the top of the columns and the result doesn't look great as is shown in the attached image.

Also, I've read beamer: Top-aligning columns within a top-aligned frame but was wondering if I'm doing something wrong with the t, T before I start messing with things I don't quite understand (ie the \topsep, \partopsep

\documentclass{beamer}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{graphicx}
\usepackage{subfig}
\usepackage{braket}
\usepackage{geometry}
\usepackage{empheq}
\usepackage{amsmath}
\usepackage{amssymb}

\begin{document}

\begin{frame}[T]{Angular Spectrum Method}{Free Space Propagation}
    A constant index medium such as free space is: 
    \begin{itemize}
        \item isotropic \pause $\Rightarrow$ diagonal permittivity, permeability tensors \pause
        \item spatially uniform \pause $\Rightarrow$ relative permittivity and permeability are constants equal to 1 \pause
        \item Source free \pause $\Rightarrow$ $\mathbf{J} = 0$, $\rho = 0$
    \end{itemize}
    \pause
    \begin{columns}[T]
    \begin{column}[T]{.5\textwidth}
        \begin{itemize}
            \item<7-> Polarisation Independent!
            \item<8-> Modes are plane waves
        \end{itemize}
    \end{column}
    \hfill
    \begin{column}[T]{.5\textwidth}
        \begin{itemize}
            \item<7-> $ \nabla^2 \mathbf{E} - \mu_0 \mu_r \epsilon_0 \epsilon_r \dfrac{ \partial^2 \mathbf{E} }{ \partial t } = 0 $
            \item<8-> $ E_i = \sum_\mathbf{k} A_\mathbf{k} e^{ \mathbf{k} \cdot \mathbf{r} } $
            \item<8-> $ \left( \dfrac{ 2 \pi n }{ \lambda } \right)^2 = k^2 = k_x^2 + k_y^2 + k_z^2 $
        \end{itemize}
    \end{column}
    \end{columns}
\end{frame}

\end{document}

enter image description here

  • Your code has errors. Please fix them! – Gonzalo Medina Mar 4 '15 at 16:46
2

Use some \vphantoms in the itemize to the left so items on both environments have the same height:

\documentclass{beamer}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{graphicx}
\usepackage[caption=false]{subfig}
\usepackage{braket}
\usepackage{geometry}
\usepackage{empheq}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage[backend=biber,url=false,doi=false,isbn=false,firstinits=true]{biblatex}

\begin{document}

\begin{frame}{Angular Spectrum Method}{Free Space Propagation}
    A constant index medium such as free space is: 
    \begin{itemize}
        \item isotropic \pause $\Rightarrow$ diagonal permittivity, permeability tensors \pause
        \item spatially uniform \pause $\Rightarrow$ relative permittivity and permeability are constants equal to 1 \pause
        \item Source free \pause $\Rightarrow$ $\mathbf{J} = 0$, $\rho = 0$
    \end{itemize}
    \pause
    \begin{columns}[T]
    \begin{column}[T]{.5\textwidth}
        \vspace{0pt}
        \begin{itemize}
            \item<7-> Polarisation Independent!\vphantom{$ \dfrac{ \partial^2 \mathbf{E} }{ \partial t }$}
            \item<8-> Modes are plane waves\vphantom{$A_\mathbf{k} e^{ \mathbf{k} \cdot \mathbf{r} }$}
        \end{itemize}
    \end{column}
    \hfill
    \begin{column}[T]{.5\textwidth}
        \begin{itemize}
            \item<7-> $ \nabla^2 \mathbf{E} - \mu_0 \mu_r \epsilon_0 \epsilon_r \dfrac{ \partial^2 \mathbf{E} }{ \partial t } =  0 $
            \item<8-> $ E_i = \sum_\mathbf{k} A_\mathbf{k} e^{ \mathbf{k} \cdot \mathbf{r} } $
            \item<8-> $ \left( \dfrac{ 2 \pi n }{ \lambda } \right)^2 = k^2 = k_x^2 + k_y^2 + k_z^2 $
        \end{itemize}
    \end{column}
    \end{columns}
\end{frame}

\end{document}

enter image description here

Remarks

  • Your code had a spurious & character that I deleted and [T] was not a valid option for frame.

    • You need to load subfig with caption=false, as in my example code.
  • \bold is deprecated; you should use \mathbf instead.

  • hm... the subfig doesn't create problems for me whether I have caption=false or not. (I suspect because I'm not using the latest version of beamer) Otherwise perfect thank you. – evan54 Mar 4 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.