3

I'd like to plot some measured values with TikZ, but despite "calling" LuaLaTeX I get the error message that TeX's main memory is exceeded. I can compile the plots under LuaLaTeX but it doesn't work with LaTeX calling LuaLaTeX. What can I do except deleting some values?

TeX capacity exceeded, sorry [main memory size=3000000].

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{tikz,pgfplots}
\pgfplotsset{compat=newest}

\usetikzlibrary{external}
\tikzset{external/system call={lualatex
        \tikzexternalcheckshellescape -halt-on-error -interaction=batchmode
        -jobname "\image" "\texsource"}}
\tikzexternalize[shell escape=-enable-write18]


\begin{document}

\begin{tikzpicture}

\begin{axis}[%
width=5cm,
height=10cm,
at={(0.790898in,0.967508in)},
scale only axis,
xlabel={$x~\rightarrow$},
ylabel={$y~\rightarrow$},
legend style={legend cell align=left,align=left,draw=black}
]
\addplot [color=gray,line width=.45pt,mark size=.45pt,only marks,mark=*,mark options={solid}]
table [ x expr=\thisrow{tmess}*1e6, y=uoutmess, col sep=comma] {tmessuoutmess.csv};
\addlegendentry{Messung};

\addplot [color=black,solid,line width=1.5pt]
table [x expr=\thisrow{tapprox}*1e6, y=uoutapprox, col sep=comma] {tapproxuoutapprox.csv};
\addlegendentry{Approximation};

\addplot [color=black,loosely dotted,line width=1.5pt]
table [x expr=\thisrow{tsim}*1e6,y=uoutsim, col sep=comma] {tsimuoutsim.csv};
\addlegendentry{Simulation};
\end{axis}
\end{tikzpicture}
\end{document}     

Values:

http://www72.zippyshare.com/v/QUAuSl3J/file.html

output

closed as unclear what you're asking by jlk, Martin Schröder, Paul Gaborit, Jesse, Paul Gessler Mar 7 '15 at 14:19

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    You have to call pdflatex with the -shell-escape. I'm no expert in MiKTeX, but -src shell-escape looks suspicious and it should probably be -shell-escape. – egreg Mar 6 '15 at 20:40
  • 1
    Which TeX distribution do you run? Which version of LuaTeX do you have? The latter piece of information is provided on line 1 of the log file. (I run MacTeX2014 on a MacBookPro with 8GByte of RAM, and when I compile your program under LuaTeX 0.79.1, I don't experience the problems you report.) – Mico Mar 6 '15 at 20:41
  • I'm using MiKTex 2.9.4248 and LuaTeX, Version beta-0.76.0-2013062821 (rev 4627) with pdfTeX, Version 3.14159265-2.6-1.40.15 (MiKTeX 2.9 64-bit) under Windows 8.1. - – jlk Mar 6 '15 at 21:16
  • 2
    No I meant that in your image above you have configured only latex to use shell-escape, so naturally it won't work if you are using pdflatex. I tried your example with pdflatex in a current in miktex (32bit) and it worked without problems. – Ulrike Fischer Mar 6 '15 at 22:50
  • 1
    @harryhaller: Please edit your question to include relevant information insted of burying it in comments. – Martin Schröder Mar 7 '15 at 12:29