1

This question already has an answer here:

Following instructions from Chinese typing on mac , I can type Chinese in TexShop, the characters shows properly in PDF file.

What I did is replacing

\documentclass[10pt]{article}

with

% !TEX program = XeLaTeX
% !TEX encoding = UTF-8 Unicode
\documentclass[UTF8,nofonts,10pt]{ctexart}
\setCJKmainfont[BoldFont=FandolSong-Bold.otf,ItalicFont=FandolKai-Regular.otf]{FandolSong-Regular.otf}
\setCJKsansfont[BoldFont=FandolHei-Bold.otf]{FandolHei-Regular.otf}
\setCJKmonofont{FandolFang-Regular.otf}

However, after changing the tex file header, the line spacing becomes bigger.

Before enter image description here

After enter image description here


Edit according to request from comments:

The part generating the paragraph is like this:

 \noindent Let $E/F$ be a field extension, $\alpha \in E$. The {\bf minimal polynomial} of $\alpha$ is the monic polynomial of least degree among all polynomials in $F[x]$ having $\alpha$ as a root; it exists when $\alpha$ is algebraic over $F$, that is, when $f(\alpha) = 0$ for some non-zero polynomial $f(x) \in F[x]$.  最小多项式

The whole tex file is as below (I copied the header from somewhere else, not really understand every line)

% !TEX program = XeLaTeX
% !TEX encoding = UTF-8 Unicode
\documentclass[UTF8,nofonts,10pt]{ctexart}
\setCJKmainfont[BoldFont=FandolSong-Bold.otf,ItalicFont=FandolKai-Regular.otf]{FandolSong-Regular.otf}
\setCJKsansfont[BoldFont=FandolHei-Bold.otf]{FandolHei-Regular.otf}
\setCJKmonofont{FandolFang-Regular.otf}

\usepackage{amsfonts,amssymb,amsmath,amsthm,epsfig,latexsym}
\newcommand{\nc}{\newcommand}
\def\nr{\par \noindent}

\theoremstyle{plain}
\newtheorem{theorem}{Theorem}
\newtheorem{lemma}{Lemma}
\newtheorem{definition}{Definition}
\newtheorem{prop}{Proposition}
\newtheorem{corollary}{Corollary}
\newtheorem{remark}{Remark}

% This is FULLPAGE.STY by H.Partl, Version 2 as of 15 Dec 1988.
% Document Style Option to fill the paper just like Plain TeX.
\typeout{Style Option FULLPAGE Version 2 as of 15 Dec 1988}

\topmargin 0pt \advance \topmargin by -\headheight \advance
\topmargin by -\headsep

\textheight 8.9in

\oddsidemargin 0pt \evensidemargin \oddsidemargin \marginparwidth
0.5in

\textwidth 6.5in
% For users of A4 paper: The above values are suited for american 8.5x11in
% paper. If your output driver performs a conversion for A4 paper, keep
% those values. If your output driver conforms to the TeX standard (1in/1in),
% then you should add the following commands to center the text on A4 paper:

% \advance\hoffset by -3mm  % A4 is narrower.
% \advance\voffset by  8mm  % A4 is taller.

\begin{document}
 \noindent Let $E/F$ be a field extension, $\alpha \in E$. The {\bf minimal polynomial} of $\alpha$ is the monic polynomial of least degree among all polynomials in $F[x]$ having $\alpha$ as a root; it exists when $\alpha$ is algebraic over $F$, that is, when $f(\alpha) = 0$ for some non-zero polynomial $f(x) \in F[x]$.  最小多项式

\end{document}

marked as duplicate by Leo Liu, moewe, user13907, percusse, Torbjørn T. Mar 8 '15 at 13:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Could you provide a complete code, e.g the one which produced the output above? – Franck Pastor Mar 7 '15 at 8:13
  • Note: I've changed the beginning of your XeLaTeX code. You had put the instruction % !TEX encoding = UTF-8 Unicode on the same line as % !TEX program = XeLaTeX, which probably made the former comment ineffective. – Franck Pastor Mar 7 '15 at 8:15
  • 1
    Is it a Chinese document or an English document with a few Chinese characters? The ctex bundle changes the document layout a lot, including the line spacing. You can use \linespread{1} to make the text single spaced. – Leo Liu Mar 7 '15 at 8:34
  • @LeoLiu I'm just testing. So do you mean if i) it's a Chinese document, then I can use \linspread{1} to reduce the line spacing? ii) if it's an English document with a few Chinese characters, is there another way, say, avoiding ctex bundle? – athos Mar 7 '15 at 9:10
  • 1
    @athos: Exactly. If it is an English document, you can just use xeCJK and set the fonts. See also tex.stackexchange.com/a/17637/2674 – Leo Liu Mar 7 '15 at 9:27

Browse other questions tagged or ask your own question.