7

I can't be the first person who has wanted to use stix with the nomath option, but it seems impossible:

\documentclass{article}
\usepackage[nomath]{stix}
\begin{document}
\end{document}

This produces

! Incomplete \iffalse; all text was ignored after line 57.
<inserted text> 
                \fi 
l.3 \begin
          {document}
3
  • 2
    And report the bug! (Information on page 3 of the manual.)
    – cfr
    Mar 8 '15 at 23:53
  • 3
    Apparently you were the first!
    – egreg
    Mar 9 '15 at 0:03
  • @cfr, thank you for the good advice. Unfortunately I can't seem to get into my old SourceForge account. Since DavidCarlisle (tex.stackexchange.com/questions/232089/…) already reported it, it shouldn't last long.
    – LSpice
    Mar 9 '15 at 0:31
8

This is a bug in the package right at the end there is the line

\def\stix@dotlessi{\ifmmode\imath\else\i}

which should say

\def\stix@dotlessi{\ifmmode\imath\else\i\fi}

Because of the interaction with the package option you can not really "patch" that with a redefinition, make a local copy and just edit the file.

4
  • Thanks for this, and for fixing the typo in my sample code. (Is there any really easy way to C&P from an external file? A literal C&P misses the four spaces at the beginning, so I was lazy and just re-typed, obviously incorrectly.)
    – LSpice
    Mar 8 '15 at 23:53
  • 2
    @LSpice highlight the code with mouse then use the {} button in the editor (or type control-k) and the indent gets added, Mar 8 '15 at 23:54
  • 2
    @LSpice I pinged a representative of stipub about this, so I guess it will get fixed shortly. Mar 8 '15 at 23:55
  • 2
    I uploaded a new version of the package to CTAN which should fix this (in TeX Live 2015 at least). Apr 17 '15 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.