2

I ran into the error when compiling the same files on a desktop and a laptop. I run XeTeX as part of MikTeX 2.9.

The MWE test2.tex is:

\documentclass{article}
\usepackage{lipsum}
\makeindex
\begin{filecontents*}{test2.xdy}  
(define-location-class "arabic-page-numbers"
    ("arabic-numbers") :min-range-length 1)
\end{filecontents*}

\begin{document}

\index{law}
\lipsum[1]
\index{law|seealso{system}}

\end{document}

and the xindy log on the laptop is:

Command Line:   C:\Users\me\Documents\localtexmf\miktex\bin\texindy.bat "test2.idx" -M "test2.xdy"
Startup Folder: C:\Users\me\Documents\Law\Brunoy

Opening logfile "nul" (done)
Reading indexstyle...
Loading module "FZjbLHpwTY"...
Loading module "lang/general/latin9-lang.xdy"...
Loading module "lang/general/latin9.xdy"...
Finished loading module "lang/general/latin9.xdy".
Finished loading module "lang/general/latin9-lang.xdy".
Loading module "tex/inputenc/latin.xdy"...
Finished loading module "tex/inputenc/latin.xdy".
Loading module "texindy.xdy"...
Loading module "numeric-sort.xdy"...
Finished loading module "numeric-sort.xdy".
Loading module "latex.xdy"...
Loading module "tex.xdy"...
Finished loading module "tex.xdy".
Finished loading module "latex.xdy".
Loading module "latex-loc-fmts.xdy"...
Finished loading module "latex-loc-fmts.xdy".
Loading module "makeindex.xdy"...
Finished loading module "makeindex.xdy".
Loading module "latin-lettergroups.xdy"...
Finished loading module "latin-lettergroups.xdy".
Finished loading module "texindy.xdy".
Loading module "page-ranges.xdy"...
Finished loading module "page-ranges.xdy".
Loading module "word-order.xdy"...
Finished loading module "word-order.xdy".
Loading module "test2.xdy"...
WARNING: redefining location-reference-class `"arabic-page-numbers"' !
Finished loading module "test2.xdy".
Finished loading module "FZjbLHpwTY".
Finished reading indexstyle.
Finalizing indexstyle... (done)

Reading raw-index "4hBqChFmSb"...
Finished reading raw-index.

Processing index... [10%]
ERROR: SLOT-VALUE: The class #<STANDARD-CLASS LOCREF:CROSSREF-LOCATION-REFERENCE> has no slot named BASE:ORDNUMS

Removing the two lines in test2.xdy eliminates the problem. Commenting out any of the three lines between \begin{document} and \end{documents} also removes the problem.

While paring down my files to reach a MWE I got a variant of the error with "...no slot named BASE:TARGET".

No problems on the desktop, under the same version of MikTeX (2.9).

  • I can't reproduce with current TeX Live.... – cfr Mar 9 '15 at 2:02
2

I'm not an expert for xindy, but the exotic error will disappear with the following:

\documentclass{article}
\usepackage{lipsum}
\makeindex
\begin{filecontents*}{test2.xdy}
(define-crossref-class "see also")
(define-location-class "arabic-page-numbers"
    ("arabic-numbers") :min-range-length 1)
\end{filecontents*}
\begin{document}
\index{law}
\lipsum[1]
\index{system}
\index{law|seealso{system}}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.