2

I am trying to update my TeX Live Utility so I can update my distribution, but when I attempt to update, it fails for some reason. I am using a Mac. Here is what the log says about the problem:

2015-03-10 08:30:57 +0000 Notice tlu_ipctask[589]   Uncompressing TeX Live Manager Updater.....................................................................................
............................................................................................
.....
2015-03-10 08:30:57 +0000 Warning tlu_ipctask[589]  ./runme.sh: line 11: kpsewhich:
 command not found

2015-03-10 08:30:57 +0000 Warning tlu_ipctask[589]  ./runme.sh: Cannot find TeX Live 
root using kpsewhich --var-value=SELFAUTOPARENT.

2015-03-10 08:30:57 +0000 Warning tlu_ipctask[589]  ./runme.sh: Please set your PATH as
 needed, otherwise it's hopeless.

2015-03-10 08:30:57 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][399]
kqueue noted that pid 590 exited (/var/folders/d_/f_t6bp352kzfkh654mqsr9280000gn/T/TLMInfraUpdateOperation.jNERhr/update-tlmgr-latest.sh --nox11)

2015-03-10 08:30:57 +0000 Notice tlu_ipctask[589]   child process pid = 590 exited

2015-03-10 08:30:58 +0000 Error tlu_ipctask[589]    Value of errno is No such file or directory

2015-03-10 08:30:58 +0000 Error tlu_ipctask[589]    *** ERROR *** exit status of pid = 590 was 1

2015-03-10 08:30:58 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][399]
waitpid returned 589, WIFEXITED(256) = 1, errno = 93 (Attribute not found)

2015-03-10 08:30:58 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][399]  
kqueue noted that tlu_ipctask (pid = 589) exited with status 1

2015-03-10 08:30:58 +0000 Notice -[TLMInfraUpdateOperation main][399]   
Removed temp directory "/var/folders/d_/f_t6bp352kzfkh654mqsr9280000gn/T/TLMInfraUpdateOperation.jNERhr"

2015-03-10 08:31:08 +0000 Notice -[TLMLogWindowController awakeFromNib][399]    
Loaded log window controller

UPDATE (several hours after original post): I tried updating manually via Terminal, and presumably it worked. However, when I then tried to update my packages via Texlive Utility, it downloaded for a while but at the end another error occurred. It seems the process was successful up until near the end, where these errors appear in the log:

2015-03-10 13:18:12 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine pdftex ...


2015-03-10 13:20:06 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine pdftex.

2015-03-10 13:20:06 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine eptex ...

2015-03-10 13:21:00 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine eptex.

2015-03-10 13:21:00 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine aleph ...

2015-03-10 13:21:52 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine aleph.

2015-03-10 13:21:52 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine uptex ...

2015-03-10 13:22:41 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine uptex.

2015-03-10 13:22:41 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine ptex ...

2015-03-10 13:23:32 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine ptex.

2015-03-10 13:23:32 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine euptex ...

2015-03-10 13:24:28 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --no-error-if-no-format --byengine euptex.

2015-03-10 13:24:28 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt mf ...

2015-03-10 13:25:19 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt mf.

2015-03-10 13:25:19 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt cont-en ...

2015-03-10 13:26:20 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt cont-en.

2015-03-10 13:26:20 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt pdfcsplain ...

2015-03-10 13:27:14 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt pdfcsplain.

2015-03-10 13:27:14 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt lualatex ...

2015-03-10 13:28:05 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt lualatex.

2015-03-10 13:28:05 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt dvilualatex ...

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  done running fmtutil-sys 
--no-error-if-no-engine=luajittex --byfmt dvilualatex.

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.dat" ...

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.dat" failed (status 127), output:

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  sh: fmtutil-sys: command not found

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.def" ...

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.def" failed (status 127), output:

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  sh: fmtutil-sys: command not found

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  running fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.dat.lua" ...

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  fmtutil-sys 
--no-error-if-no-engine=luajittex --byhyphen "/usr/local/texlive/2014/texmf-
var/tex/generic/config/language.dat.lua" failed (status 127), output:

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  sh: fmtutil-sys: command not found

2015-03-10 13:28:55 +0000 Warning tlu_ipctask[903]  

2015-03-10 13:28:55 +0000 Notice -[TLMLogServer _parseMessageAndNotify:][718]   
Unhandled status "exiting "

2015-03-10 13:28:55 +0000 Notice tlu_ipctask[903]   exiting tlmgr:

2015-03-10 13:28:55 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][718]  
kqueue noted that pid 904 exited (/usr/texbin/tlmgr --repository 
http://ctan.imsc.res.in/systems/texlive/tlnet/ --machine-readable --persistent-downloads 
update --all)

2015-03-10 13:28:55 +0000 Notice tlu_ipctask[903]   child process pid = 904 exited

2015-03-10 13:28:56 +0000 Error tlu_ipctask[903]    Value of errno is No such file or directory

2015-03-10 13:28:56 +0000 Error tlu_ipctask[903]    *** ERROR *** exit status of pid = 904 was 1

2015-03-10 13:28:56 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][718]  
waitpid returned 903, WIFEXITED(256) = 1, errno = 2 (No such file or directory)

2015-03-10 13:28:56 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][718]  
kqueue noted that tlu_ipctask (pid = 903) exited with status 1

closed as off-topic by Mensch, Jesse, Svend Tveskæg, moewe, Martin Schröder Oct 9 '15 at 18:41

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you look at what repository is being used? – egreg Mar 10 '15 at 9:13
  • This is the address: ctan.imsc.res.in/systems/texlive/tlnet I am located in Nepal so this is probably why it's an Indian site. – Paul Mar 10 '15 at 9:33
  • 1
    Quite strange. Can you try issuing sudo tlmgr update --self from a terminal window? The administrator password will be asked for; don't worry, it's safe. – egreg Mar 10 '15 at 9:41
  • I did this, and I guess it updated the utility. However, when I tried to then update my packages by means of the Texlive Utility, it downloaded for a while and then failed again. I put the log results in the question above. – Paul Mar 10 '15 at 14:02
  • 4
    I'm voting to close this question as off-topic because some days late the update runs without problems (see last comment of OP). – Mensch Oct 9 '15 at 17:29

Browse other questions tagged or ask your own question.