11

I know I can tweak $clean_ext setting inside .latexmkrc to clean specific files when invoking latexmk -c. However, it doesn't work for directory.

The directory I want to clean is _minted-<main document name>. I have tried _minted-%R, ./_minted-%R, ./_minted-%R/*. None of them work.

  • Do you have the output directory ($out_dir) set? – John Collins Mar 16 '15 at 13:34
  • 1
    @JohnCollins No, I haven't. Everything are in default. – xucheng Mar 17 '15 at 8:01
  • 1
    Actually there is a bug in latexmk. It assumes that %R is the first item in the pattern you give in $clean_ext. I'll need to correct that. – John Collins Mar 17 '15 at 13:08
  • 1
    @JohnCollins any progress in fixing this? I also would like to see this. – languitar May 11 '17 at 11:33
  • 1
    I forgot to fix the bug. It'll be fixed in v. 4.61, which is planned to be released today. – John Collins Oct 25 '18 at 13:39
4

The only currently available solution is to turn off caching in minted using \usepackage[cache=false]{minted}.

@JohnCollins: unlink_or_move in latexmk.pl does not handle recursive directory removal as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.