1

I am making a document in LyX but my figures are labelled here as figure 2.1, figure 3.1, figure 3.2 etc instead of figure 1, figure 2etc. How can I fix this issue?

  • More or less duplicate of How to control figure numbering in Lyx I think. If the 2 in figure 2.1 is the chapter number you need chapter in counterwithout of course. – Torbjørn T. Mar 10 '15 at 20:14
  • 1
    i corrected that by making changes in Dcument-> settings-> modules -> deleting "figure name by sections" It worked! – faiza Mar 10 '15 at 20:37
2

As you discover ...

Document > Settings... > Modules > Number Figures by Section > Delete

mwe

This remove \numberwithin{figure}{section} in the LaTeX Preamble (as well as \usepackage{amsmath} if not needed by another command).

Note that in LaTeX preamble you can use also the chngcntr package to control the numeration of floats. See Continuous v. per-chapter/section numbering of figures, tables, and other document elements for more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.