3

I want to print specific slides from one frame using Acrobat under Microsoft Windows (I don't have a choice here...).

Specifically, for instance, I want to print the 6th and and 12th slide of my second frame, which corresponds to actual pages 14 and 20 in the PDF.

I have always used Evince on GNU/Linux before, and when I would say "print pages 16 and 20", it would do exactly what I intended. So I tried the same with Acrobat, but it just printed the first slide in the 16th and 20th frames—obviously not at all what I wanted.

Is there a way to con Acrobat into doing exactly what I want from it? Unfortunately, using a different operating system, modifying the LaTeX source, and/or printing both slides separately are not an option.

Terminlogic clarifications

It has been pointed out that my use of "slide", "page", etc. was not clear, so I have reworded my question making the following terminologic assumption:

  • By "frame", I mean an actual Beamer \frame, and the "frame number" is the one that would be output by \insertframenumber
  • By "slide", I mean a page in the resulting PDF document, therefore a \frame with two \pauses contains three slides
  • By "page", I mean the page number that is shown in parentheses in Acrobat or Evince, or the only page number that is shown in xpdf or GSview—for instance, when I'm looking at the 6th slide in the 2nd frame, I see "2 (14 of 158)", so the 6th slide of the 2nd frame is page 14
  • 1
    Can you please clarify all the page/slide numbers in your question? It's quite confusing as written... Thanks! :-) – darthbith Mar 11 '15 at 14:56
  • @darthbith, Thanks for pointing that out. I have tried to look up what terminology is normally used with Beamer and reworded my question accordingly. – scozy Mar 11 '15 at 15:57
  • Quick fix is to navigate to the page and just use the option to print the current page. (Not great if you do this often but useful if you urgently need 1 or 2 slides.) – cfr Mar 12 '15 at 0:14
5

This is a setting that's buried in the Adobe Reader preferences. According to this message on Adobe's forums you need to disable logical page numbering. That's under "Edit->Preferences" (or CTRL+k), in the "Categories" on the left choose "Page Display", then under the "Page Content and Information" header, uncheck "Use logical page numbers", which is the third checkbox in the left column. Apparently the option is the same for at least Adobe Readers X and XI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.