2

can you please help me to avoid the warning that arises by using:

twoside=true, fontsize=10pt, BCOR=8mm, \recalctypearea

Here is my example:

\documentclass{scrreprt}

\usepackage{microtype}
\usepackage{blindtext}
\usepackage{hyperref}
\usepackage[automark]{scrlayer-scrpage}   % für angepasste Kopf-/Fußzeilen
\KOMAoptions{headsepline=0.2ex}

\KOMAoptions{twoside=true}
\KOMAoptions{fontsize=10pt}
\KOMAoptions{paper=A5}
\KOMAoptions{headinclude=true}
\KOMAoptions{footinclude=false}
\KOMAoptions{mpinclude=false}

\KOMAoptions{BCOR=8mm}
%\KOMAoptions{DIV=18}
\KOMAoptions{DIV=calc}
\recalctypearea

\begin{document}
    \blinddocument
\end{document}

Doing so, why do I need to set

\KOMAoptions{DIV=calc} 

before the other \KOMAoptions to avoid a warning.

  • You could try the silence package. Or simply learn to ignore the message (the KOMA classes like to warn about a lot of things) – Ulrike Fischer Mar 12 '15 at 11:17
5

If you include the option pagesize, everything gets calculated correctly. No need for \recalctypearea here.

% arara: pdflatex

\documentclass[%
    ,twoside=true
    ,fontsize=10pt
    ,paper=a5
    ,pagesize % this was missing.
    ,BCOR=8mm
    ,headinclude=true
    ,footinclude=false
    ,mpinclude=false
    ,headsepline=0.2ex
    ,DIV=calc
    ]{scrreprt}

\usepackage[automark]{scrlayer-scrpage}   % für angepasste Kopf-/Fußzeilen
\usepackage{blindtext}
\recalctypearea % not needed here, but in order to show that it is working without warnings.

\begin{document}
\blinddocument
\end{document}
  • Thank you so much, that works for me. That leads to correct page layout without hyperref, too. – Tobias Mar 12 '15 at 12:08
  • Option pagesize is default since KOMA-Script v3.17. – Schweinebacke Mar 3 '17 at 16:47
  • Your solution is more to move the options to \documentclass instead of setting them by single \KOMAoptions commands. – Schweinebacke Mar 3 '17 at 16:50
3

To avoid the warning change the order of \KOMAoptions{BCOR=8mm} and \KOMAoptions{DIV=18} or use \typearea[8mm]{18} to set BCOR and DIV at the same time.

\documentclass[pagesize]{scrreprt}% -> default: paper=a4, fontsize=11pt -> DIV=10

\usepackage{microtype}
\usepackage{blindtext}
\usepackage{hyperref}
\usepackage[automark]{scrlayer-scrpage}

\KOMAoptions{headsepline=0.2ex}

\KOMAoptions{twoside=true}% -> recalculation of the page layout
\KOMAoptions{fontsize=10pt}
\KOMAoptions{paper=A5}
\KOMAoptions{headinclude=true}
\KOMAoptions{footinclude=false}
\KOMAoptions{mpinclude=false}

\KOMAoptions{DIV=18}% -> recalculation of the page layout
\KOMAoptions{BCOR=8mm}% -> recalculation of the page layout

\begin{document}
    \blinddocument
\end{document}

If you use \KOMAoptions{BCOR=8mm} before you set the DIV value to 18 (or calc) the DIV value used in the recalculation of the page layout is too low for paper=A5. So you get a warning.

  • I did not know that the order of these commands is important. Thanks for the additional explenation. – Tobias Mar 13 '15 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.