1

I would like to create a remotely accessible, centralized .bib bibliography on GitHub that I can use in my .Rnw and .tex files in various directories. It would also make it easier to collaborate and decrease files in constant transit amongst collaborators. As an aside, I am more familiar with working with a GUI IDE like RStudio rather than the command line.

I tried Googling and found a few leads that didn't end up working. In particular, I found a guide on using submodules, but couldn't get it to work. I already tried \bibliography{https://github.com/usernamehere/MyProjects.git/bibliography.bib}, but this also did not work. Can someone please provide me with some new leads to explore?

Update:

Still can't get it to work. Taking the suggestions of Guido and Alan Munn in the comments below, I have tried a variation of the following MWE pseudocode (pseudo, because I omit my Git user name for anonymity). Am I making a mistake somewhere that prevents the citations from showing up?

** Temporarily left my GitHub username in place for a MWE **

\documentclass{article}  
\usepackage[backend=biber]{biblatex}  
\addbibresource[location=remote]{https://raw.githubusercontent.com/aw236/myrefs/master/myrefs.bib}

% Variations attempted that don't work:
% \addbibresource[location=remote]{https://github.com/aw236/myrefs/myrefs.bib}
% \addbibresource[location=remote,type=file]{https://github.com/aw236/myrefs/myrefs.bib}

\begin{document}
asdf.

\nocite{*}
\printbibliography
\end{document}

closed as off-topic by moewe, user31729, darthbith, Zarko, Tom Bombadil Nov 4 '15 at 11:21

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Try using \addbibresource[location=remote]{https:// etc.} The \bibliography command is deprecated in biblatex. – Alan Munn Mar 12 '15 at 20:49
  • 1
    You should try with \addbibresource[location=remote]{http:...}. Also, there is a trailing / before https, and the manual specifies that only ftp and http protocols are supported. – Guido Mar 12 '15 at 20:50
  • @Guido Thanks. It appears that it also works with https though: tex.stackexchange.com/questions/176325/…. I modified my post above with MWE (pseudocode to protect anonymity). – user2205916 Mar 13 '15 at 2:27
  • the url should point to a bib file. There is a / at the end. – Guido Mar 13 '15 at 2:34
  • 4
    I'm voting to close this question as off-topic because it is solved by a software update (running the MWE with Biber version 2.2 works perfectly fine). – moewe Nov 4 '15 at 10:05

Browse other questions tagged or ask your own question.