4

I'm typesetting a whole bible and I'm trying to reproduce some special quotes of it using the quote environment and some macros. These quotes have indentation when there is a new line (\\), and the hyphenated word are unindented.

Here is an image depicting the desired effect:

enter image description here

Here is the minimal working example that shows the real output (please ignore other format details). Again, the first line of the quote is longer than the rest, but the word "embarazos:" should be unindented. The rest is ok.

\documentclass[a4paper,10pt, twocolumn,openany]{book}
\usepackage[utf8]{inputenc}
\usepackage[spanish]{babel}
\usepackage{mathpazo}
\usepackage{lettrine}
\addto\captionsspanish{\renewcommand{\partname}{Libro de}} 

\newlength{\vl}
\newcounter{Verso}
\newcounter{Cap}
\setcounter{Verso}{1}
\setcounter{Cap}{1}
\usepackage[usenames,dvipsnames,svgnames,table]{xcolor}
\newcommand{\jChapter}[1]{\par\bigskip\lettrine{{\textcolor{red}{#1}}}{}}

\newcommand{\vs}{%
\settowidth{\vl}{\tiny{\arabic{Verso}}}%
\textsuperscript{\tiny{\arabic{Verso}}}% 
\stepcounter{Verso}%
}%

\newcommand{\ch}{%
\arabic{Cap}%
\chapter*{\theCap}%
\jChapter{\theCap}%
\stepcounter{Cap}%
\setcounter{Verso}{1}%
}%

\newcommand{\cita}[1]{\begin{quote}\vspace{-0.5\baselineskip}#1\end{quote}}
\newcommand{\cm}[1]{\flqq#1\frqq}
\newcommand{\pr}[1]{¿#1?}   
\begin{document}
\part*{Génesis}
\section*{Primer relato de la creación}
\ch

\vs{}A la mujer le dijo: \cita{\cm{Tantas haré tus fatigas cuantos sean tus embarazos:\\con dolor parirás a los hijos.\\Hacia tu marido ira tu 
apetencia,\\y él te dominará.}}

\end{document}

How should I modify my code in order to get the desired result?

4
  • 2
    I am very confused as the picture shows all of the lines of the quote indented except for the hyphenated word. I think That is what you want, that any wrapped lines (whether at a hyphen or not) are not indented. Commented Mar 12, 2015 at 21:05
  • You should at \parindent <length> to your quote environment'. I think, in general, the way you are inputting the biblical texts could be improved/simplified. The most obvious problem is the reliance on `\`.
    – jon
    Commented Mar 12, 2015 at 21:09
  • @DavidCarlisle: Yes, you're right. Sorry for the mistake.
    – Charlie
    Commented Mar 12, 2015 at 21:23
  • You say 'but the word "embarazos:" should be indented' but it is indented by the code you post. Presumably you want it like the picture (and my answer) not indented? Commented Mar 12, 2015 at 21:58

1 Answer 1

5

(Updated answer after OP posted more information about intend look of cited/quoted material. Provided further updates to address additional questions.)

If I understand your objectives correctly, using a quote environment is not the way to go -- the quote environments indents its material on both sides, not just on the left.

Instead, I suggest setting up an environment that increases the value of \parindent locally. Inside the new environment, use blank lines to start the (typographic) equivalent of new paragraphs.

enter image description here

\documentclass[a4paper,10pt, twocolumn,openany]{book}
\usepackage[utf8]{inputenc}
\usepackage[spanish]{babel}
\usepackage{newpxtext,newpxmath}%{mathpazo}
\usepackage{lettrine}
\addto\captionsspanish{\renewcommand{\partname}{Libro de}} 

\newlength{\vl}
\newcounter{Verso}
\newcounter{Cap}
\setcounter{Verso}{1}
\setcounter{Cap}{1}
\usepackage[usenames,dvipsnames,svgnames,table]{xcolor}
\newcommand{\jChapter}[1]{\par\bigskip\lettrine{{\textcolor{red}{#1}}}{}}

\newcommand{\vs}{%
\settowidth{\vl}{\tiny{\arabic{Verso}}}%
\textsuperscript{\tiny{\arabic{Verso}}}% 
\stepcounter{Verso}%
}%

\newcommand{\ch}{%
\arabic{Cap}%
\chapter*{\theCap}%
\jChapter{\theCap}%
\stepcounter{Cap}%
\setcounter{Verso}{1}%
}%

\newenvironment{cita}%
  {\begingroup%
   \addtolength{\parindent}{1em}%
   \flqq}%
  {\frqq
   \par
   \endgroup}

\newcommand{\cm}[1]{\flqq#1\frqq}
\newcommand{\pr}[1]{¿#1?}   
\begin{document}
\part*{Génesis}
\section*{Primer relato de la creación}
\ch

\vs{}A la mujer le dijo:

\begin{cita}%
Tantas haré tus fatigas cuantos sean tus embarazos:

con dolor parirás a los hijos.

Hacia tu marido ira tu apetencia,

y él te dominará.%
\end{cita}

(More text after \texttt{cita} environment, starting with normal 
indentation of first line of paragraph)
\hrule % just to illustrate full width of text block


\end{document}
13
  • Oh you might be right. (Although given the clarity of the question it is hard to know:-) I think I'll delete my answer anyway. Commented Mar 12, 2015 at 22:19
  • THanks for your question, but the whole quote isn't indented. According to the screenshot I posted, the whole quote should be indented, except the hyphenated word. I gave you a vote anyway ;)
    – Charlie
    Commented Mar 13, 2015 at 4:22
  • 1
    @Charlie - I've updated my answer to reflect the information you've given in the comments. Let me just remark that the new screenshot you've provided does not indicate that the "quoted" material should be left-indented differently from the surrounding material.
    – Mico
    Commented Mar 13, 2015 at 5:46
  • 1
    @DavidCarlisle - My updated answer generates output that looks very much like the one given in your (currently deleted) answer. Let me know if you want to resurrect [term chosen deliberately, in view of the material being typeset...] your answer, and I'll delete mine...
    – Mico
    Commented Mar 13, 2015 at 5:50
  • 1
    @Charlie - I honestly can't explain what may be going on in your TeX system. I've posted a bit of additional code to illustrate that the "normal amount" of paragraph indentation is restored after the cita environment -- as defined in the example itself -- ends.
    – Mico
    Commented Mar 15, 2015 at 6:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .