Why won't biber-biblatex work with memoir? Seems that this is a longstanding issue, but I have not discovered any reliable resolution. In this mwe I get errors (i'm summarizing) like undefined refs and citations, cannot find .bib file, biber didn't find bib file, failed to resolve 1 citation. [biber 1.9, biblatex 2.9a, memoir 3.7b, macOS X]

Several references suggest that you delete the biber par-cache in terminal, located at:

$ biber -- cache

I've done this numerous times, but it still doesn't work.

Incidentally, I have run biber-biblatex with the standard article and book classes. Most of the time, the files compile. When I get errors, deleting the cache usually works. Not so with memoir. I have placed the .bib file in the same directory as the main file and in a designated directory -- like /Users/username/Library/texmf/bibtex/bib/bibfile.bib (my preference). Are their cautions, best practices, secrets, tips that users should be aware of to make this work in memoir?

    Address = {New York},
    Author = {Donald E. Knuth },
    Publisher = {Addison-Wesley},
    Title = {The TeXbook},
    Year = {1986}}



The TeX reference \cite{knu86}
%The TeX reference \parencite{knu86}



closed as unclear what you're asking by moewe, user13907, Andrew, Fran, Svend Tveskæg Apr 5 '15 at 9:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 7
    I regularly use biber and biblatex with memoir. The cache deletion is an (annoying) unrelated problem. Your example compiles without problem for me. – Andrew Swann Mar 13 '15 at 11:46
  • 6
    The documentclass should normally have no bearing on your bilbatex experience (some more specific classes load incompatible bibliography packages or change other things to cause trouble, the "big" "standard" classes such as memoir and koma do not). Your MWE worked just fine on my system. What exact errors do you get if you start with a clean directory (delete all auxiliary files) and run (pdf)LaTeX, Biber, (pdf)LaTeX, (pdf)LaTeX? – moewe Mar 13 '15 at 11:52
  • @Andrew Swann No such success for me. The file compiles just fine, as it has been. Very strange. Even created a new file, but no bibliography or proper cite. – zun Mar 13 '15 at 13:10
  • 1
    How are you compiling the file? Many interfaces run past the cache error from biber; you need to delete that cache and run biber again. Once the cache is there it won't go away before you do the deletion and it won't produce a bibliography. – Andrew Swann Mar 13 '15 at 13:13
  • @moewe I started with a clean directory by deleting all the auxillary files. Didn't work. Then created a brand new directory with only one file, the main.tex. Still didn't work. Errors: Biber error: [386] Utils.pm:160> ERROR - Cannot find 'sbk.bib'! Latexmk: Biber did't find bib file [sbk.bib] Latexmk: Summary of warnings: Latex failed to resolve 1 citation(s) Latexmk: All targets (a1test.pdf) are up-to-date. Tried one more time with brand new file a3test.tex in another new directory. This time it worked! – zun Mar 13 '15 at 13:19

Andrew Swann and moewe noted one or more of the conditions below when working with memoir and biber/biblatex. So, this is meant to collect their comments, or others, and close out the question. There is no indication that this is a problem confined to memoir.

(1) ''cache deletion is an (annoying) unrelated problem''. For now it seems that we all have to just continue to grin and bear it.

(2) documentclass should normally have no bearing on your biblatex experience

(3) deleting the cache and re-running the file seems to have risen to the level of a method (judging by the evidence and suggestion of many, many users).

(4) Check .blg file in case a helpful message is written

(5) You can improve your chances of compilation by starting with a clean directory, retaining only main.tex and bibfile.bib. (graphic files, .sty files and others probably don't count)

(6) The .bib file just might be corrupted in some way not easily detected. I noticed that BibDesk inserted a couple of lines in its file. There may be others.

Date-Added = {2015-03-13 01:03:59 +0000},
Date-Modified = {2015-03-13 01:05:31 +0000},

Those lines may be a source of problems for BibDesk users. Manually removing them seemed to help my case.

(7) Running your BibDesk or other .bib file through a utility like BBEdit's `Zap Gremlins' may help if there are spurious characters lurking in the file.

Here, I repeat what other users have already stated over time about locating and deleting the cache. They are here just to sort of complete the post comments.

To locate the cache in terminal, run

biber --cache   

To remove the cache with one stroke, so to speak

rm -rf `biber --cache` 

Not the answer you're looking for? Browse other questions tagged or ask your own question.