Does anyone know how to make Aquamacs Command/Texing Option default to the Lualatex engine? I've checked the preferences but, so far no luck. I have the feeling this is a no-brainer and I'm missing the obvious...


Assuming you're using AUCTeX (which I think Aquamacs ships with), either of

(setq-default TeX-engine 'luatex)


M-x customize-variable RET TeX-engine RET

will work.

  • Could you tell me please how to type the code in - I'm not a programmer and am a bit lost. Thanks
    – Mike
    Mar 14 '15 at 19:33

Digging through the AucTeX options, there is an option for setting the TeXing options in which, it is possible to choose from a list of engines then it's possible to choose the one required. Making sure to save everything at each step everything now works perfectly.

  • It sounds like you have answered this yourself, however, you haven't given any details. Can you please expand on your answer so that other people who stumble across your question can see how you solved this.
    – user30471
    Mar 14 '15 at 20:26
  • 1
    I think he found what Sean Allread suggested in his answer (customize-variable RET TeX-engine RET)
    – giordano
    Mar 15 '15 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.