4

I would like to create slides using this theme for Beamer but am having trouble getting it to work. I just copied the .sty files into /home/gthomson/texmf/tex/latex/mtheme.

However the theme requires the Fira font and links to another site where I downloaded this font. However I did not know where to put it so I copied the .otf files into home/gthomson/texmf/fonts/opentype/Fira following the advice in this post. But when I try to run the demo .tex file using xelatex I get:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
! fontspec error: "font-not-found"
! 
! The font "Fira Sans Light" cannot be found.
! 
! See the fontspec documentation for further information.
! 
! For immediate help type H <return>.
!...............................................

... several times.

How can I get this to work?

Currently I am running Elementary OS "Luna" with Texlive 2012. I looked for a package that already has this font and installed and tried texlive-fonts-extra.

Looking at this post and also the one linked to above it appears that I might need to update the font map files but I do not know what this means or how to do it?

Any help is appreciated

2
  • 2
    Without a full example there is some guesswork here: you are using either XeLaTeX or LuaLaTeX and the fontspec package plus a file looking for a system font (Fira Sans Light). Do you actually have that font installed? This will not be part of your TeX system, but rather installed for general use.
    – Joseph Wright
    Mar 15, 2015 at 9:30
  • By the way a newer version of the font is available on the same website: carrois.com/fira-4-1
    – s__C
    Apr 24, 2015 at 17:20

3 Answers 3

2

I assume that you use XeLaTeX or luaLaTeX (which are necessary for fontspec).

If this is true, those programs must know which fonts are available on your system. For that you must typefc-cache in a terminal after the installation of the font to update the cache of fontconfig. To verify if the system is aware of the font, you can type, in a terminal something like :fc-list | grep -i fira which should list all the fonts whith "fira" in the name.

I don't know if fontconfig search a font in a personal texmf by default. If this is not the case, you could make a link from .fonts in your personal directory to the Fira directory and run fc-cache to update the cache of fontconfig.

3
  • @G_T As you accepted the answer, could you tell what you have done to solve the problem? I am experiencing the exact same issue and couldn't solve it.
    – ed82
    Mar 18, 2015 at 13:08
  • I think I accepted this answer as I had not actually installed the font, merely copy-and-pasted the files. I think the best solution now is to upgrade Texlive.
    – G_T
    May 26, 2015 at 5:39
  • The accepted answer kind of worked for me, but, additionally, I had to first include the texlive fontconfig file to the search paths of fc-cache, as suggested here. Apr 7, 2021 at 0:35
2

In file beamerfontthememetropolis.sty from the theme, change the line

\setsansfont[BoldFont={Fira Sans}]{Fira Sans Light}

to

\setsansfont[BoldFont={Fira Sans},ItalicFont={Fira Sans Light Italic}]{Fira Sans Light}

I don't know why luaLaTeX need to specify the italic font explicitly, because XeLaTex compiles the demo file without any problem on my system (Windows+MikTeX).

In addition, you might also want to change

\defaultfontfeatures{Mapping=tex-text}

line to

\defaultfontfeatures{Ligatures=TeX}

to get the theme fully compatible with luaLaTeX.

0

see in https://tug.org/FontCatalogue/firasans/ the proposed usage:

\usepackage[sfdefault]{FiraSans} %% option 'sfdefault' activates Fira Sans as the default text font \usepackage[T1]{fontenc} \renewcommand*\oldstylenums[1]{{\firaoldstyle #1}}

It worked for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .