1

I was using Texmaker on Linux for a couple of internships, now I moved to Mac OS X, and I'm really not a pro user with such an OS.

I've already read the user manual and I've checked here to find out if someone has my same problem, so I hope I'm not repeating any questions.

I'm just trying to produce the very first PDF from a template I'm writing down, and I obtain this:

-synctex=1 -interaction=nonstopmode %.tex

I get is a problem of configuration, but I don't know what should I insert in the configuration panel.

This is my file:

\documentclass[12pt,a4paper,twocolumn]{report}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\author{Bruno Pescara}
\title{Investigation of ionization relaxation dynamics via femtosecond laser-spectoscopy}
\begin{document}
\index{•}
\chapter{introduction}
abilità di guardare nel piccolo sia come dimensione ma anche come velocità, pensavano che la spettroscopia fosse finita ma poi hanno fatto sta cosa ed è andata come è adata
\chapter{Theory}
\section{mass spectroscopy}
\section{electron ionization}
\section{particle size analysis}
\chapter{Methods}
\section{mass spectroscopy}
\section{electron ionization}
\section{particle size analysis}
\chapter{Results}
\section{mass spectroscopy}
\section{electron ionization}
\section{particle size analysis}
\chapter{Discussion}
\tableofcontents
\end{document}

I'm using Texmaker version 4.4.1 and Mac OS X Yosemite (the last one).

closed as unclear what you're asking by doncherry, Symbol 1, user31729, jubobs, Malipivo Apr 15 '15 at 15:41

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried running something like latex your_filename.tex straight from the terminal? – egwene sedai Mar 16 '15 at 9:20
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Symbol 1 Mar 16 '15 at 9:25
1

First you should make sure, that you have a complete and correct TeX system installed which includes above all the distribution, an editor and maybe a PDF viewer. The recommended distribution for OS X is MacTeX. Download and install it.

To check whether everything works fine, create a minimal document named testfile.tex

% testfile.tex
\documentclass{article}

\begin{document}
Hello World!
\end{document}

and save it on your desktop. Then open the Terminal and navigate to the folder into which you saved the file, in this case ~/Desktop/, with

cd ~/Desktop/

and then run pdflatex with

pdflatex testfile.tex

That should generate a PDF containing “Hello World!” (and a page number). If this worked your TeX distribution was installed correctly.


Now you maybe have to change the setting of you editor. For pdflatex the setting should be

pdflatex -synctex=1 -interaction=nonstopmode %.tex

where pdflatex is the TeX program, -synctex=1 -interaction=nonstopmode are options and %.tex the placeholder for the actual file. With this setting you should now be able to compile the file in you editor. If this doesn’t work try this setting:

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex

Not the answer you're looking for? Browse other questions tagged or ask your own question.