0

I have tried getting bibtex to work using the latex filename bibtex filename latex filename latx filename commands I DID NOT USE bibtex mybib and I still get the error "I couldn't open file name 'blabla'" Numerous people have posted a similar problem, but I cannot find a single answer that actually addresses the error, instead of just pointing out that bibtex filename should be used and not bibtex mybib. enter image description here

Does anybody know a real solution to my problem? Please...I have been searching the internet for over an hour.

I would like to point out that I usually use Latexila, and I tried the command prompt after Latexila failed to compile bibtex. The error messages were essentially the same in Latexila as the command prompt. enter image description here

I also tried putting the tex file name into the /bibliography{filename} command: enter image description here

I have also tried a long list of other variations, that would take pages to list and describe here...nothing works.

  • What operating sysstem? What IDE (TexMaker, kile,et c)? What distribution of LaTeX (Miktex, TexLIve or other)? But without any extra information, I suspect you have a path problem. – R. Schumacher Mar 16 '15 at 23:47
  • 3
    It looks (reading between the lines) that your file is called article.tex and you used the command bibtex article.tex which would be wrong. the command should be bibtex article – David Carlisle Mar 16 '15 at 23:48
  • I also tried compiling using the Latexila interface and got the same error. – Panda Logique Mar 17 '15 at 0:00
  • I am working in ubuntu 14.04 – Panda Logique Mar 17 '15 at 0:00
  • I typed exactly what the error messages said, but I do not know how to added the actual text to the forum post. – Panda Logique Mar 17 '15 at 0:02
1

The input file for the command bibtex is the .aux file. The extension is optional. If the specified file name does not end in .aux, then the extension is appended. The specified file name in the screen shot ends in .tex, thus bibtex has added .aux and the resulted file name does not exist. Solution: Just omit the extension .tex, then bibtex finds the auxiliary file name, written by the LaTeX run.

The next issue is the bibliography database:

The LaTeX run writes the argument of \bibliography{...} into the .aux file as \bibdata{...}. Then bibtex adds the extension .bib and wants to read the file. Usually the file does not contain an absolute path name, often the .bib file is in the same directory as the .tex file. Then bibtex will fail to find the .bib file, if the current directory is different.

Therefore I would first go to the directory with the .tex, .aux and .bib files:

cd /home/ninja/Documents/294/Articles_For_Idea2_Methane

Then the bibtex command becomes:

bibtex 'Chem294_ProjectIdea(2)_16_March_15'

or

bibtex 'Chem294_ProjectIdea(2)_16_March_15.aux'
  • This does not work. I get the same errors for both attempts – Panda Logique Mar 17 '15 at 0:25
  • I have tried this and I get: "bash: syntax error near unexpected token '('" when I do not use the file directory with the bibtex command. I tried renaming my tex file with the () removed from around the 2. I started over with "latex Chem294_ProjectIdea2_16_March_15" Now it says "! I can't find file Chem294_ProjectIdea2_16_March_15" – Panda Logique Mar 17 '15 at 0:29
  • This still does not work for me I got the same errors working in the directory as noted in my above comment – Panda Logique Mar 17 '15 at 0:45
  • 1
    @PandaLogique The answer contains single quotes (linux) because of the parentheses inside the file name. The file name should work with the correct quoting. Of course, simplifying the file name is also not a bad idea. The "file not found error" is probably based on a spelling error. The command ls for a directory listing or the file name completion feature of bash can help to find the correct file name. – Heiko Oberdiek Mar 17 '15 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.