I use texstudio in Ubuntu and I would like to use svg package:


File `svg.sty' not found. ^^M

The only thing I found is a closed thread.

My attempt for installation of this package has failed:

$ tlmgr install svg
(running on Debian, switching to user mode!)
cannot setup TLPDB in /home/ar2015/texmf at /usr/bin/tlmgr line 5336.

Where am I wrong?


This is my code:

\caption{Previous output \label{overflow}}

Please avoid linking to posts which do not solve the problem straight forward.

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. The best thing to do is to figure out in which package Debian puts the package svg. That is, Debian will put a bunch of related LaTeX packages into one Debian package. Find out which one and install that using your regular package manager (not tlmgr). That is, if you wish to use Debian's packages for TeX Live, stick to them. – cfr Mar 17 '15 at 0:03
  • The svg CTAN package is part of your distribution's texlive-latex-extra package. Install that (texlive-latex-extra) with your distribution's package manager. – Paul Gessler Mar 17 '15 at 0:05
  • @PaulGessler texlive-latex-extra is 558 MB so I used --no-install-recommends switch to reduce it into 48 MB. Now there is no error on latex package calling but I see this problem Unknown graphics extension: .svg. ...raphics[width=140mm]{images/pos_after.svg} – ar2015 Mar 17 '15 at 0:10
  • Did you read the documentation for the svg package? You should not use \includegraphics but \includesvg[<options>]{<svg filename>} instead, for SVG files. – Paul Gessler Mar 17 '15 at 0:12
  • @PaulGessler I think it looks for a .pdf_tex file. – ar2015 Mar 17 '15 at 0:19

The problem was solved according to the suggestion of Paul Gessler

I just added --no-install-recommends to reduce the size of the installed Ubuntu package:

sudo apt-get --no-install-recommends install  texlive-latex-extra
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.