2

To produce my figures, I often use Inkscape with its export in Pdf+LaTeX feature. It allows to create a PDF associated with a TeX file which contains the text. Such TeX files have the specific extension .pdf_tex instead of .tex, which is convenient to make obvious they are linked to a PDF file.

The problem is: Kile does not recognize them as real TeX files and its behavior changes: for example the Comment/Uncomment tool is not available.

Is there a way to tell Kile to recognize a .pdf_tex (or any other user defined extension) as it does for a .tex?

Thank you for your help.

  • I wouldn't consider .pdf_tex as a convenient extension. Why not just file-pdf.tex or something like this? – yo' Mar 17 '15 at 11:29
  • 2
    You can manually set Tools -> Highlighting -> Markup -> LaTeX. – Astrinus Mar 17 '15 at 12:19
  • @yo' : I agree with you, but this is imposed by Inkscape. – Tobard Mar 17 '15 at 12:44
  • @Astrinus : Thank you, that is what I was looking for. Any suggestion to apply this setting automatically? – Tobard Mar 17 '15 at 12:46
2

You can manually set Tools -> Highlighting -> Markup -> LaTeX.

For autorecognition you can try to add the custom extension to the TeX MIME type in your system settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.