2

I need to submit an article to a journal with Vancouver style referencing. Vancouver style can be used simply by including \bibliographystyle{vancouver}. The .bst is defined as here: https://www.ctan.org/tex-archive/biblio/bibtex/contrib/vancouver

The journal also requires a DOI after the reference. I have included these into my .bib. For example:

@ARTICLE{Berglund2001,
  author = {Berglund, Anders and Gunilla Rosenqvist},
  title = {Male pipefish prefer ornamented females},
  journal = {Animal Behaviour},
  year = {2001},
  pages = {345-350},
  doi = {10.1006/anbe.2000.1599}
}

However, this DOI is not automatically printed in my bibliography. A related question is posted here: URL of cited web site in bibliography. The DOI is defined in Vancouver, as can be seen when opening the .bst. Therefore, I think there should be an easy way to make it print the DOI as well, without the need to change the bibliographystyle.

How can I add DOI to the bibliography when using Vancouver style?

1 Answer 1

5

The answer is provided here: http://mirrors.ctan.org/biblio/bibtex/contrib/vancouver/FAQ.

The doi formatting is disabled by default. You can enable it by changing the following line in vancouver.bst from:

#0 'adddoiresolver := % 0=no DOI resolver; 1=include it

to:

#1 'adddoiresolver := % 0=no DOI resolver; 1=include it
3
  • I figured out the answer while writing up this question. It was silly of me not to figure it out earlier. Anyway, I decided to continue posting the question, as well as the answer, on here.
    – LBogaardt
    Mar 18, 2015 at 12:01
  • If anyone can help me figure out how to change the DOI part into a DOI-URL hyperlink, that would be appreciated. The answer is probably contained within .bst, but I'm not familiar enough with this type of code to do it myself.
    – LBogaardt
    Mar 18, 2015 at 12:02
  • Ok, this is done by changing the #0 in "#0 'hrefform := % 0=no crossrefs; 1=hypertex xrefs; 2=hyperref refs" to #2.
    – LBogaardt
    Mar 18, 2015 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.