2

When I try to adjust parskip in eledmac, it only takes effect when the paragraph starts with a label.

For example:

%!TEX TS-program =  xelatex
\documentclass{scrartcl}
\usepackage{libertine}
\usepackage{eledmac}

\parskip=\baselineskip

\begin{document}
\beginnumbering

\pstart
\noindent \textsc{Dubitabit autem aliquis etc.} Consequenter quaeritur
circa istam partem ubi philosophus movet dubitationem circa motum
caeli. Movet ibi istam dubitationem utrum caelum dependeat ab aliquo
in motu suo. Ideo quaeritur utrum caelum in motu suo dependeat ab
aliquo corpore fixo et immobili.\pend

\pstart 
\emph{1.} Et arguitur quod non. 
\pend

\pstart 
Consequenter quaeritur circa istam partem ubi philosophus
movet dubitationem circa motum caeli. Movet ibi istam dubitationem
utrum caelum dependeat ab aliquo in motu suo. Ideo quaeritur utrum
caelum in motu suo dependeat ab aliquo corpore fixo et immobili.
\pend

\pstart
\label{test-label} Consequenter quaeritur circa istam partem ubi
philosophus movet dubitationem circa motum caeli. Movet ibi istam
dubitationem utrum caelum dependeat ab aliquo in motu suo. Ideo
quaeritur utrum caelum in motu suo dependeat ab aliquo corpore fixo et
immobili.  
\pend

\endnumbering
\end{document}

Gives this result. enter image description here

Is this expected behavior? Any ideas?

  • Note scrartcl has the parskip=on option for making such a setting, however the output still has the same strange spacing. – Andrew Swann Mar 19 '15 at 12:15
1

It's more the default behavior of eledmac which change when a edlabel begin a pstart than a bug. Nore ledmac, nore eledmac were conceptualized to add this parskip (it is lost when the splitting process is made) and just the \edlabel/\label called at the begining insert it by mistake (you could prevent it by adding \leavevmode before).

So the solution will be to use \cs{AtEveryPend} to insert it manually.

\documentclass{book}


\usepackage{libertine}
\usepackage{eledmac}

\parskip=\baselineskip
\AtEveryPend{\vskip\parskip}

\begin{document}
\beginnumbering

\pstart
\noindent \textsc{Dubitabit autem aliquis etc.} Consequenter quaeritur
circa istam partem ubi philosophus movet dubitationem circa motum
caeli. Movet ibi istam dubitationem utrum caelum dependeat ab aliquo
in motu suo. Ideo quaeritur utrum caelum in motu suo dependeat ab
aliquo corpore fixo et immobili.\pend

\pstart 
\emph{1.} Et arguitur quod non. 
\pend

\pstart 
\strut Consequenter quaeritur circa istam partem ubi philosophus
movet dubitationem circa motum caeli. Movet ibi istam dubitationem
utrum caelum dependeat ab aliquo in motu suo. Ideo quaeritur utrum
caelum in motu suo dependeat ab aliquo corpore fixo et immobili.
\pend

\pstart
\leavevmode\label{test-label} Consequenter quaeritur circa istam partem ubi
philosophus movet dubitationem circa motum caeli. Movet ibi istam
dubitationem utrum caelum dependeat ab aliquo in motu suo. Ideo
quaeritur utrum caelum in motu suo dependeat ab aliquo corpore fixo et
immobili.  
\pend

\endnumbering
\end{document}

You could also open an issue on github to ask for such option.

  • you'r welcome. But please open an issue, I think many people could ask for it ;-) – Maïeul Mar 19 '15 at 15:30
  • I don't understand what this issue should request. Is there any reason to make a specific feature for changing \parskip when I can just use the \AtEveryPend? – Stenskjaer Mar 19 '15 at 20:16
  • it's more about handbook, to prevent people ask again. – Maïeul Mar 19 '15 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.