3

since the last update (v1.1k) of the biblatex-ieee package the protection of capital letters for the whole title doesn't work anymore. I am using misc as entrytype and I want to keep the whole title as it is by using {{Title...}}.

@MISC{bibkey,
      author = {D. Duck},
      title = {{Skriptum zur VU Automatisierung (WS 2014/15)}},
      year = {2014},
      address = {Institut XYZ, Universität ABC}
}

I figured out that v1.1k introduced the command \bbx@colon@search to capitalise after colon in titles. (That command takes two arguments, but with my brackets there is only one available. Thats the problem, isn't it?) Without this new command everything works fine for me as it does in older versions.

So is the way I use the brackets wrong? Or is it a problem with the last update?

Thanks for your help.

PS: I am using bibtex with biber with the following minimal example:

\documentclass{article}
\usepackage[backend=biber, style=ieee]{biblatex}
\addbibresource{bibliography.bib}
\begin{document}
    Test \cite{bibkey}
    \printbibliography{}
\end{document}
  • 1
    Welcome to TeX-sx! While the issue is clear here, this feels more like a bug report than a question. As such, I wonder if it would be better to log it at github.com/josephwright/biblatex-ieee/issues? – Joseph Wright Mar 19 '15 at 10:12
  • It definitely seems to be related to \bbx@colon@search as you say, though the trouble should not be the number of arguments. This is really more something you should report as a bug as Joseph Wright points out. For the time being \DeclareFieldFormat{titlecase}{\MakeCapital{#1}} \DeclareFieldFormat{sentencecase}{\MakeSentenceCase{#1}} is a work-around that disables this new capitalise-after-colon feature. – moewe Mar 19 '15 at 10:24
  • OK thanks. I will report that bug. I wasn't sure if it is really a bug or if just the way i use the brackets is not allowed for the whole title. – Martin Mar 19 '15 at 10:25
  • No, curly brackets around the title are allowed. But if you have a lot of German titles, you should disable auto case change for German works. I'm not entirely sure about this work around here, it might just work, \makeatletter \long\def\bbx@colon@search@aux#1#2: #3\stop{% #1#2% \ifblank{#3} {} {% : % \bbx@colon@search@aux#1#3\stop }% }. \makeatother (modulo line breaks). – moewe Mar 19 '15 at 10:28
  • JosephWright has released a fix for biblatex-ieee on github. See bug report, the fix is not yet on CTAN. – moewe Mar 25 '15 at 14:28
5

This has indeed changed in the latest version, and might be regarded as a bug. You can work around this by either putting braces around the individual letters that need capitalization or adding an extra level of braces around the whole text.

Sample output

@Misc{bibkey,
  author =   {D. Duck},
  title =    {Skriptum zur {VU} {A}utomatisierung ({WS} 2014/15)},
  year =     2014,
  address =  {Institut XYZ, Universität ABC}
}
@Misc{bibkey2,
  author =   {D. Duck},
  title =    {{{Skriptum zur VU Automatisierung (WS 2014/15)}}},
  year =     2014,
  address =  {Institut XYZ, Universität ABC}
}
\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[backend=biber, style=ieee]{biblatex}
\addbibresource{bibliography.bib}

\begin{document}

Test \cite{bibkey,bibkey2}
\printbibliography{}

\end{document}

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.