I have been using the regular \cite command for my citations all the time. But now I used the 'natbib' package and instead used \citep and \citet, but this keeps giving me errors in the natbib.sty file which it creates. I also get the error 'command \bibhang already defined'.

Does anyone have experience with this?




 \chapter*{List  of abbrevations and symbols}



as mentioned in \citet{england2002}

\section{Insurance industry}

\section{IBNR Claims and Claims Reserving}

\section{Link with GLM}

\section{Robustification and Problems}





using this .bib file:

title={Stochastic claims reserving in general insurance},
author={England, Peter D and Verrall, Richard J},
journal={British Actuarial Journal},
publisher={Cambridge Univ Press}
  • 2
    Why, for gods sake, do you want to use old and dusty natbib if you are already using the modern and full of features biblatex?
    – Johannes_B
    Commented Mar 23, 2015 at 11:34
  • 2
    Remove \usepackage{natbib} and the \bibliographystyle{..} line, but add the option "natbib" to the biblatex call. Commented Mar 23, 2015 at 11:36

1 Answer 1


There are several problems with your example code.

  • You should start by immediately removing both arguments from the document environment. The instruction should read


    rather than \begin{document}[a4paper,12pt]. The document environment does not take arguments. Nothing good is going to come from supplying arguments, optional or otherwise, to the document environment.

  • Don't load both the biblatex package and the natbib package. Select one or the other, but not both.

  • Assuming you want to continue with natbib (@Johannes_B's learned opinion notwithsstanding...), you need to observe that the ieeetr bibliography style is not compatible with authoryear-style citation call-outs. You should therefore load the natbib package with the options numbers and comma, not authoryear and comma. Don't forget to delete the instruction \addbibresource{bib/literature.bib} and to replace \printbibliography with \bibliography{bib/literature} -- note: no filename extension. By the way, with numeric-style citation call-outs in use, \citet will give you a warning message; use \cite instead.

  • If you do need or want authoryear-style citation call-outs along with IEEE-style formatted bib entries, I suggest you switch to the IEEEtranN bibliography style. If you go this route, be sure to omit the numbers option when loading natbib.

    The output from your (somewhat condensed) working example then is as follows.

enter image description here

  title    = {Stochastic claims reserving in general insurance},
  author   = {England, Peter D and Verrall, Richard J},
  journal  = {British Actuarial Journal},
  volume   = {8},
  number   = {03},
  pages    = {443--518},
  year     = {2002},
  publisher= {Cambridge University Press}

\documentclass[a4paper,12pt]{article} % just for this example

as mentioned in \citet{england2002}, \dots

  • Can you move the part with the optional arguments for the document environment higher? Though you are explaining later, the first part sounds like this is specail for natbib usage.
    – Johannes_B
    Commented Mar 23, 2015 at 20:27
  • @Johannes_B - Done. :-)
    – Mico
    Commented Mar 23, 2015 at 22:19
  • @Johannes_B - Thanks. Feel free to post a biblatex-based answer with a IEEE-related formatting option. Readers of this posting may find it useful to have two separate solutions.
    – Mico
    Commented Mar 23, 2015 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .