2

This question already has an answer here:

I can't get the BibLaTeX Package to work. When I run the 'create bibiliography'-command from TextMate I get the following error Message

INFO - This is Biber 1.9
Command bibtex exited with status 2

The Produced PDF-Document contains only

[wikipedia ]

but no bibliography.

The log of the pdftex doesn't show any useful information on this error

Document Class: scrbook 2015/02/07 v3.16 KOMA-Script document class (book)

LaTeX Warning: Citation 'wikipedia' on page 1 undefined on input line 8.
LaTeX Warning: Empty bibliography on input line 9.
LaTeX Warning: There were undefined references.

Output written on Minimalbeispiel.pdf (1 page, 18613 bytes).

a Minimalexample which produces this error is

\documentclass{scrbook}
\usepackage{biblatex}
\addbibresource{library.bib}

\begin{document}

\cite{wikipedia}
\printbibliography

\end{document}

and the library.bib-Entry is

@misc{wikipedia,
    Author = {Wikipedia},
    Note = {[Online; accessed 24-March-2015]},
    Title = {Porosity --- Wikipedia{,} The Free Encyclopedia},
    Url = {http://en.wikipedia.org/w/index.php?title=Porosity&oldid=651280533},
    Year = {2015},
    Bdsk-Url-1 = {http://en.wikipedia.org/w/index.php?title=Porosity&oldid=651280533}
}

I have already used several hours searing the Web for help but couldn't find anything helpful.

I'm using TextMate version 2.0-beta.6.8 and the MacTeX-2014 Bundle

Greetings and thanks for any Help

marked as duplicate by Andrew Swann, Svend Tveskæg, Paul Gessler, Mensch, Martin Schröder Mar 24 '15 at 13:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to TeX.SX! What is written in the .blg file? – Andrew Swann Mar 24 '15 at 11:25
  • Thanks ;) the .blg file contains only: [0] 73b5ab1d.pm:320> INFO - This is Biber 1.9 [0] 73b5ab1d.pm:323> INFO - Logfile is 'Minimalbeispiel.blg' – Kugelfisch15 Mar 24 '15 at 11:33
  • Have you tried running biber from the command line? – Andrew Swann Mar 24 '15 at 11:39
  • Is there any way to format code in the Comments? Now I've done it using "biber Minimalbeispiel.bcf" and it shows the following message: code INFO - This is Biber 1.9 INFO - Logfile is 'Minimalbeispiel.blg' read_file '/var/folders/_r/8f8_73vn7b3czxj6v01y50bh0000gn/T/par-6c6f72656e7a/cache-a3cdad92316c60c9c5179d80d6bb51a7a024393c//inc/lib/Biber/LaTeX/recode_data.xml' - sysopen: No such file or directory at /var/folders/_r/8f8_73vn7b3czxj6v01y50bh0000gn/T/par-6c6f72656e7a/cache-a3cdad92316c60c9c5179d80d6bb51a7a024393c/bda77484.pm line 112. – Kugelfisch15 Mar 24 '15 at 11:57
  • You can update your question with the code. Anyway it looks like you have the "biber cache problem", see tex.stackexchange.com/q/140814/15925 – Andrew Swann Mar 24 '15 at 12:02
3

Looks like your biber cache got corrupted. For a quick fix:

  1. Open Terminal
  2. Enter the following: biber --cache
  3. Remove the folder shown by the command

Here is a more detailed description of the bug.

Not the answer you're looking for? Browse other questions tagged or ask your own question.