1

Is there any way, other than adding per-line suppressions (i.e., %chktex 2) or per warning suppressions to get chktex to stop warning me when \vref and \eqref are preceded by spaces?

I am running chktex v1.7.2 WITHOUT the -g (use global chktexrc) flag and WITH the -l flag pointing to a local .chktexrc file, in which I have removed \vref and \eqref from the Linker options section. (Linker controls warning about needed non-breaking space when macros like \ref are used.) Despite removing these items under the Linker section, I still get warnings (warning #2) about them.

Does anyone know a way to solve this without entirely disabling warning number 2 or inserting line level suppressions everywhere?

  • 2
    Just to be clear this is about chktex not lacheck, but there was no tag for chktex and I couldn’t create one due to not enough reputation points – zbeekman Mar 24 '15 at 16:42
0

OK, it seems there is a documentation bug with chktex and the -g flag DISABLES the default chktexrc file. Using the -g flag fixes my problem.

  • I admit, the documentation is a bit confusing. Actually, -g1 will enable the global rc, and -g0 will disable it. But -g is a synonym for -g0. The default is to read the global rc. – Ivan Andrus Sep 23 '15 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.