9

After updating packages of MiKTEX 2.9 lualatex stopped working.

I execute this code:

\documentclass[12pt]{standalone}
\usepackage{tikz}
\begin{document}
\begin{tikzpicture}
\node[] at (0,0) {A};
\end{tikzpicture}
\end{document}

and I get this error:

"Process started: lualatex.exe -synctex=1 -interaction=nonstopmode "test".tex Error: Command crashed: lualatex.exe -synctex=1
-interaction=nonstopmode "test".tex Process exited with error(s)"

Why does the command crash? What should be done to continue my work?

PDFLatex and XeLatex work fine, but I need lualatex, cause my thesis is with lualatex.

13

According to Ulrike Fischer comment (see above) "Open Miktex settings, go to the tab Formats, select lualatex and click on Build" First do it in admin mode, then in user mode.

Now everything is working!

enter image description here

  • 2
    You opened miktex settings (admin). As it worked this is fine. But if a user format exists then one should use the "non-admin" miktex settings to overwrite it. – Ulrike Fischer Mar 25 '15 at 14:37
  • Doing that fixed lualatex on my workstation, but I can't seem to be able to fix an install on Windows 2003 server. Logged in as the user which lualatex runs under, built the format, but still the same problem. And pdflatex no longer works there either. This is a catastrophe. – ajeh Mar 26 '15 at 17:54
  • @UlrikeFischer After the todays update, the update program itself crashes before fetching the available updates. How are you proposing to install further updates? – ajeh Mar 26 '15 at 18:18
  • 1
    @ajeh: You can always get packages from CTAN and move them to a local repository and install from there (if mpm is still working). But I would at first try to run the manager from the command line. Btw: That pdflatex isn't working could mean that you have quite a different problem. – Ulrike Fischer Mar 26 '15 at 18:23
  • @UlrikeFischer After running settings repeatedly under the service user and logging on and off, I finally got pdflatex working. But lualatex works only under my own account (which is a domain admin) and not under the service account. What could that be? Do I need to blow away some files from the service account's home directory? – ajeh Mar 26 '15 at 18:35
1

The following steps worked for me after building format files was not sufficient (pdflatex kept throwing errors re dump file not found and lualatex just quit silently):

  1. Uninstall MikTex.
  2. Blow away all instances of MikTex folders under all of the user's folders.
  3. Reinstall MikTex (the most recent version).

In my special scenario there were additional steps required due to running lualatex from an ASP.NET web page under a service account using impersonation, but the first 3 at least allowed the regular users to compile.

  • 2
    The usual Windows voodo: Reinstall the software. :-( – Martin Schröder Mar 27 '15 at 11:45
  • 2
    After I spent almost entire day trying to restore business as usual after the accursed update killed everything, and the proposed solution worked only for the users who had the admin rights, the solution I posted worked for everyone. Think of that before you downvote and then think again before trying to justify downvoting. – ajeh Mar 27 '15 at 19:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.