1

Unfortunately I had to reinstall my Windows and I installed MiKTeX using the 64 bit installer and everything went fine including running TeXworks and compiling something (so I assume everything is installed correctly).

But, no matter which editor I try (and I tried several) none of them pick up where the MiKTeX is installed and because of that they can't compile anything. Here's how my TeXstudio looks:

I have no idea what I did wrong since I tried reinstalling MiKTeX several times.

  • Can the relevant binaries be found in your system's PATH? Try opening cmd.exe and typing pdflatex --version or something similar. Do you get any output? – d125q Mar 25 '15 at 18:08
  • I get the following output: MiKTeX-pdfTeX 2.9.5496 (1.40.15) (MiKTeX 2.9 64-bit) Copyright (C) 1982 D. E. Knuth, (C) 1996-2014 Han The Thanh TeX is a trademark of the American Mathematical Society. So I assume it works! – RidableCthulu Mar 25 '15 at 18:09
  • you can't do this your self by hand? I think you didnt do enything wrong but texwork is associted with miktex and texstudio not. – touhami Mar 25 '15 at 18:27
  • I am not an experienced user and I don't want to enter and commands that are not correct. The problem is that I always installed it like this and TeXstudio always picked up the commands. – RidableCthulu Mar 25 '15 at 18:29
2

At the first startup (or to be more precise, when there is no settings file yet), TXS tries to detect existing LaTeX installations.

If you started TXS without having a LaTeX installation, the commands will be empty. You can repeat the detection by restoring to the default settings.

If that doesn't work, here is a screenshot of the default command configuration:

enter image description here

  • Thank you very much for answering. I already took care of it by doing the last thing myself so it's working now! – RidableCthulu Apr 3 '15 at 18:46
  • 1
    +1. This kind of issue seems to be decently common, i.e. users installing TeXstudio before a TeX distribution. Would it be possible to implement something like a test so that if all the *TeX engines are <unknown> at startup, TeXstudio asks if it should do the detection again? – doncherry Apr 3 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.